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Getting Started

The Video and Image Processing Blockset™ software is a tool for processing
images and video in the Simulink® environment. This chapter provides an
introduction to the Video and Image Processing Blockset software, its product
requirements, and its documentation.

® “Product Overview” on page 1-2

¢ “Installation” on page 1-3

¢ “Product Demos” on page 1-5

¢ “Working with the Documentation” on page 1-7

e “Key Blockset Concepts” on page 1-11

¢ “Block Data Type Support” on page 1-29

* “Image Credits” on page 1-30
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Product Overview

1-2

The Video and Image Processing Blockset software is a tool used for the rapid
design, prototyping, graphical simulation, and efficient code generation of
video processing algorithms. Video and Image Processing Blockset blocks
can process images or video data. These blocks can import streaming video
into the Simulink environment and perform two-dimensional filtering,
geometric and frequency transforms, block processing, motion estimation,
edge detection and other signal processing algorithms. You can also use the
blockset in conjunction with Real-Time Workshop® to automatically generate
embeddable C code for real-time execution.

Video and Image Processing Blockset blocks support floating-point, integer,
and fixed-point data types. To use any data type other than double-precision
and single-precision floating point, you must install Simulink® Fixed Point™
software. For more information about this product, see the Simulink Fixed
Point documentation.



Installation

Installation

In this section...

“Installing the Video and Image Processing Blockset Software” on page 1-3
“Required Products” on page 1-4

“Related Products” on page 1-4

Installing the Video and Image Processing Blockset
Software

Before you begin working with theVideo and Image Processing Blockset
software, you need to install the product on your computer.

Installation from a DVD

Video and Image Processing Blockset blocks follow the same installation
procedure as the MATLAB® toolboxes:

1 Start the MathWorks™ installer.

2 When prompted, select the Product check boxes for the products you
want to install.

The documentation is installed along with the products.

Installation from a Web Download

You can use your MathWorks Account to download products from the
MathWorks Web site:

1 Navigate to http://www.mathworks.com/web_downloads/.
2 Click Download products.

3 Log in to the system using your MathWorks Account e-mail and password.
If you do not have a MathWorks Account, you can create one from this
Web page.

4 Select your platform and the products you want to install.

1-3
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5 Follow the instructions on the Download and Install screen, which
describe how to download the product(s) and the installer.

6 Double-click the Installer.exe file to run the installer.
7 When prompted, enter your Personal License Password.
8 Select the Product check boxes for the products you want to install.

The documentation is installed along with the products.

Required Products

The Video and Image Processing Blockset software is part of a

family of products from The MathWorks™. You need to install

several products to use the Video and Image Processing Blockset
software. For more information, see the MathWorks Web site at
http://www.mathworks.com/products/viprocessing/requirements.jsp

Related Products

The MathWorks provide several products that are relevant to the kinds of
tasks you can perform with the Video and Image Processing Blockset software.

For more information about any of these products, see either

¢ The online documentation for that product if it is installed on your system

® The MathWorks Web site, at
http://www.mathworks.com/products/viprocessing/related.jsp
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Product Demos

In this section...

“Demos in the Help Browser” on page 1-5
“Demos on the Web” on page 1-5
“Demos on MATLAB Central” on page 1-6

Demos in the Help Browser

You can find interactive Video and Image Processing Blockset demos in the
MATLAB Help browser. This example shows you how to locate and open a
typical demo:

1 To open the Help browser to the Demos tab, type demos at the MATLAB
command line.

2 On the left side of the Help browser, double-click Blocksets, and then
double-click Video and Image Processing to see a list of demo categories.

3 The Pattern matching demo, which demonstrates object tracking in a video
stream, is a typical Video and Image Processing Blockset demo. To view
the description of this demo, double-click Detection and Tracking, and
then click Pattern matching.

4 Click Open this model to display the Simulink model for this demo. Run
the model by selecting Start from the Simulation menu in the model
window.

Demos on the Web

The MathWorks Web site contains demos that show you how to use the
Video and Image Processing Blocksetsoftware. You can find these demos at
http://www.mathworks.com/products/viprocessing/demos. jsp.

You can run these demos without having MATLAB or Video and Image
Processing Blockset software installed on your system.
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Demos on MATLAB Central

The MATLAB Central website contains files, including demos, contributed
by users and developers of Video and Image Processing Blockset software,
MATLAB, Simulink and other products. Contributors submit their files to
one of a list of categories. You can browse these categories to find submissions
that pertain to Video and Image Processing Blockset software or a specific
problem that you would like to solve. MATLAB Central is located at
http://www.mathworks.com/matlabcentral/.
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Working with the Documentation

In this section...

“Viewing the Documentation” on page 1-7

“Printing the Documentation” on page 1-8

“Using This Guide” on page 1-8

Viewing the Documentation

You can access the Video and Image Processing Blockset documentation using
files you installed on your system or from the Web using the MathWorks
Web site.

Documentation in the Help Browser

This procedure shows you how to use the MATLAB Help browser to view the
Video and Image Processing Blockset documentation installed on your system:

1 In the MATLAB window, from the Help menu, click Product Help. The
Help browser opens.

2 From the list of products in the left pane, click Video and Image
Processing Blockset. In the right pane, the Help browser displays the
Video and Image Processing Blockset Roadmap page.

3 Under the section titled Documentation Set, select User’s Guide. The
Help browser displays the chapters of this manual.

The Help browser also has a Demos tab where you can view product demos.
For more information, see “Product Demos” on page 1-5.

Documentation on the Web

You can also view the documentation from the MathWorks Web site. The
documentation available on these Web pages is for the latest release,
regardless of whether the release was distributed on a DVD or as a Web
download:
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1 Navigate to the Video and Image Processing Blockset Product page at
http://www.mathworks.com/products/viprocessing/.

2 On the right side of the page, click the Documentation link. The Video
and Image Processing Blockset documentation is displayed.

Printing the Documentation

The documentation for the Video and Image Processing Blockset software is
also available in printable PDF format. You need to install Adobe Acrobat
Reader 4.0 or later to open and read these files. To download a free copy of
Acrobat Reader, see http://www.adobe.com/products/acrobat/main.html.

The following procedure shows you how to view the documentation in PDF
format:

1 In the MATLAB window, from the Help menu, click Product Help. The
Help browser opens.

2 From the list of products in the left pane, click Video and Image
Processing Blockset. In the right pane, the Help browser displays the
Video and Image Processing Blockset Roadmap page.

3 Under the Printing the Documentation Set heading, click the links
to view PDF versions of the Video and Image Processing Blockset
documentation.

Using This Guide
To help you effectively read and use this guide, here is a brief description of
the chapters and a suggested reading path.

Expected Background

This manual assumes that you are familiar with the following:
e The MATLAB language, to write scripts and functions with M-code, and to
use functions with the command-line interface

¢ The Simulink environment, to create simple models as block diagrams
and simulate those models
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What Chapter Should | Read?

Follow the procedures in this guide to become familiar with the blockset’s
functionality. The User’s Guide contains tutorial sections that are designed
to help you become familiar with using the Simulink and Video and Image
Processing Blockset software:

¢ Read Chapter 1, “Getting Started” to learn about the installation process,
the products required to run Video and Image Processing Blockset blocks,
and to view the Video and Image Processing Blockset demos.

¢ Read Chapter 2, “Importing and Exporting Images and Video” to
understand how video is interpreted by the Simulink blocks. Also, learn
how to bring video data into a model, display it on your monitor, and export
it to an AVI file.

¢ Read Chapter 3, “Viewing Video” to learn how to use the MPlay GUI to
view videos that are represented as variables in the MATLAB workspace.
You can also learn how to use it to view video files or video signals in
Simulink models.

¢ Read Chapter 5, “Conversions” to learn how to convert an intensity image
to a binary image, how to convert color information between color spaces,
and how to downsample the chroma components of an image.

¢ Read Chapter 6, “Geometric Transformation” to understand how blocks in
the Geometric Transformations library interpolate values. You also learn
how to rotate, resize, and crop images.

¢ Read Chapter 7, “Morphological Operations” to learn about morphological
operations and which blocks can be used to perform them. For example,
you learn how to count objects in an image and correct for nonuniform
illumination.

¢ Read to learn how to sharpen, blur, and remove noise from images. You
also learn how to find object boundaries and calculate the histogram of
the R, G, and B values in an image.

¢ Read Chapter 8, “Example Applications” to learn how to track the motion
of an object in a video stream. Also, learn more about motion compensation
and image compression.

For a description of each block’s operation, parameters, and characteristics, see
the Block Reference in the Video and Image Processing Blockset documentation
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on the Web at http://www.mathworks.com/products/viprocessing/ or
in the Help browser.
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Key Blockset Concepts

In this section...

“Image Types” on page 1-11

“Video in the Video and Image Processing Blockset Blocks” on page 1-12
“Defining Intensity and Color” on page 1-12

“Color Image Processing” on page 1-13

“Coordinate Systems” on page 1-20

“Image Data Stored in Column-Major Format” on page 1-22

“Sample Time” on page 1-22

“Video Duration and Simulation Time” on page 1-23

“Acceleration Modes” on page 1-24

“Strategies for Real-Time Video Processing” on page 1-25

“Code Generation” on page 1-27

Image Types

In the Video and Image Processing Blockset software, images are real-valued
ordered sets of color or intensity data. The blocks interpret input matrices as
images, where each element of the matrix corresponds to a single pixel in the
displayed image. Images can be binary, intensity (grayscale), or RGB. This
section explains how to represent these types of images.

Binary Images
Binary images are represented by a Boolean matrix of Os and 1s, which
correspond to black and white pixels, respectively.

For more information, see “Binary Images” in the Image Processing Toolbox™
documentation.
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Intensity Images

Intensity images are represented by a matrix of intensity values. While
intensity images are not stored with colormaps, you can use a gray colormap
to display them.

For more information, see “Grayscale Images” in the Image Processing
Toolbox documentation.

RGB Images

RGB images are also known as a true-color images. With Video and Image
Processing Blockset blocks, these images are represented by an array,
where the first plane represents the red pixel intensities, the second plane
represents the green pixel intensities, and the third plane represents the blue
pixel intensities. In the Video and Image Processing Blockset software, you
can pass RGB images between blocks as three separate color planes or as
one multidimensional array.

For more information, see “Truecolor Images” in the Image Processing
Toolbox documentation.

Video in the Video and Image Processing Blockset
Blocks

Video data is a series of images over time. Video in binary or intensity format
is a series of single images. Video in RGB format is a series of matrices
grouped into sets of three, where each matrix represents an R, G, or B plane.

Defining Intensity and Color

The values in a binary, intensity, or RGB image can be different data types.
The data type of the image values determines which values correspond to
black and white as well as the absence or saturation of color. The following
table summarizes the interpretation of the upper and lower bound of each
data type. To view the data types of the signals at each port, from the Format
menu, point to Port/Signal Displays, and select Port Data Types.
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Black or Absence of | White or Saturation
Data Type Color of Color
Fixed point Minimum data type Maximum data type
value value
Floating point 0 1

Note The Video and Image Processing Blockset software considers any data
type other than double-precision floating point and single-precision floating
point to be fixed point.

For example, for an intensity image whose image values are 8-bit unsigned
integers, 0 is black and 255 is white. For an intensity image whose image
values are double-precision floating point, 0 is black and 1 is white. For an
intensity image whose image values are 16-bit signed integers, -32768 is
black and 32767 is white.

For an RGB image whose image values are 8-bit unsigned integers, 0 0 0
is black, 255 255 255 is white, 255 0 0 is red, 0 255 0 is green, and 0 0 255
is blue. For an RGB image whose image values are double-precision
floating point, 0 0 0 is black, 1 1 1 is white, 1 0 0 is red, 0 1 O is green,
and 0 0 1 is blue. For an RGB image whose image values are 16-bit
signed integers, -32768 -32768 -32768 is black, 32767 32767 32767 is
white, 32767 -32768 -32768 is red, -32768 32767 -32768 is green, and
-32768 -32768 32767 is blue.

Color Image Processing

The Video and Image Processing Blockset software enables you to work with
color images and video signals as multidimensional arrays. For example,
the following model passes a color image from a source block to a sink block
using a 384-by-512-by-3 array.

1-13



Getting Started

1-14

10
File Edit VYiew Simulation Format  Tools Help
D& &=l e 4202 =m0 [Nomal x|

peppers.png

Irnzge

[Zaax 512%3]

Image From File

= I rnage

Video
Wiewer

Wideo Viewer

Ready [10d%

[odeas




Key Blockset Concepts

) video Viewer O] x|
File Tools Wiew Playback Help ~
B[ 0% /&G o

CRR o e

Feady RGE 354512 T=10.000

You can choose to process the image as a multidimensional array by setting

the Image signal parameter to One multidimensional signal in the Image
From File block dialog box.
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[Z]source Block Parameters: Image From File x|

Image Fram File

Reads an image from a file.

|Jze the File name parameter to gpecify the image file you want bo import into pour
model. Uge the Sample time parameter to zet the zample period of the block.

I Drata Types |

Parameters

File name: Ipeppers.png Browse. . |

Sample tirme: Iinf

Image signal:l One multidimensional signal :I

0k I Cancel | Help |

The blocks that support multidimensional arrays meet at least one of the
following criteria:
® They have the Image signal parameter on their block mask.

® They have a note in their block reference pages that says, “This block
supports intensity and color images on its ports.”

® Their input and output ports are labeled “Image”.
You can also choose to work with the individual color planes of images or

video signals. For example, the following model passes a color image from a
source block to a sink block using three separate color planes.
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To process the individual color planes of an image or video signal, set the
Image signal parameter to Separate color signals in both the Image
From File and Video Viewer block dialog boxes.
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E Source Block Parameters: Image From File x|

Image From File

Reads an image from a file.

|Jze the File hame parameter to specify the image file you want ta impart into your
model. Uge the Sample time parameter to zet the zample period of the block.

I Drata Types |

—Parameters
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Sample time: Iinf
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Expart to Imaage Toal Ctrl+E
Close Chrl+w
Close all

Note The ability to output separate color signals is a legacy option. It is
recommend that you use multidimensional signals to represent color data.

If you are working with a block that only outputs multidimensional arrays,
you can use the Selector block to separate the color planes. For an example
of this process, see . If you are working with a block that only accepts
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multidimensional arrays, you can use the Matrix Concatenation block to
create a multidimensional array. For an example of this process, see .

Coordinate Systems

You can specify locations in images using various coordinate systems. This
topic discusses pixel coordinates and spatial coordinates, which are the two
main coordinate systems used in the Video and Image Processing Blockset
software.

Pixel Coordinates

Pixel coordinates enable you to specify locations in images. In this coordinate
system, the image is treated as a grid of discrete elements, ordered from top
to bottom and left to right, as shown in the following figure:

0 1 2

For pixel coordinates, the first component r (the row) increases downward,
while the second component ¢ (the column) increases to the right. Pixel
coordinates are integer values and range from 0 to the length of the row or
column. The pixel coordinates used in Video and Image Processing Blockset
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software are zero based, while the pixel coordinates used by Image Processing
Toolbox and MATLAB are one based. For more information on the pixel
coordinate system used by Image Processing Toolbox, see “Pixel Coordinates”
in the Image Processing Toolbox documentation.

Spatial Coordinates

Spatial coordinates enable you to specify a location in an image with greater
granularity than pixel coordinates. For example, in the pixel coordinate
system, a pixel is treated as a discrete unit, uniquely identified by an integer
row and column pair, such as (3,4). In a spatial coordinate system, locations
in an image can be represented in terms of partial pixels, such as (3.3, 4.7).
The following figure illustrates the spatial coordinate system used for images:

-0.5 0 0.5 1 1.5 2 2.5
-0.5 ; i } > C
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|
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I

25 ———— L1 —————

This spatial coordinate system corresponds to the pixel coordinate system

in the following ways. First, both are defined in terms of row and column
positions. Second, the spatial coordinates of the center point of any pixel are
identical to the pixel coordinates for that pixel. However, the pixel coordinate
system is discrete, while the spatial coordinate system is continuous. This
means that, in pixel coordinates, the upper-left corner of an image is (0,0),
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while in spatial coordinates, this location is (-0.5,-0.5). The spatial coordinate
system used by the Video and Image Processing Blockset software differs
from the one used by Image Processing Toolbox. For more information on this
spatial coordinate system, see “Spatial Coordinates” in the Image Processing
Toolbox documentation.

Image Data Stored in Column-Major Format

The MATLAB technical computing software and Video and Image Processing
Blockset blocks use column-major data organization. The blocks’ data buffers
store data elements from the first column first, then data elements from the
second column second, and so on through the last column.

If you have imported an image or a video stream into the MATLAB workspace
using a function from the MATLAB environment or the Image Processing
Toolbox, the Video and Image Processing Blockset blocks will display this
image or video stream correctly. If you have written your own function or
code to import images into the MATLAB environment, you must take the
column-major convention into account.

Sample Time

Because the Video and Image Processing blocks calculate values directly
rather than solving differential equations, you must configure the Simulink
Solver to behave like a scheduler that uses each block’s sample time to
determine when the code behind the block is executed. The following steps
show you how to do this:

1 From the model’s Simulation menu, select Configuration Parameters.
The Configuration dialog box opens.

2 From the Type list, choose Fixed-step.

3 From the Solver list, choose Discrete (no continuous states).

The following figure shows the correctly configured Configuration dialog
box.
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The Solver, while in scheduler mode, uses a block’s sample time to determine
when the code behind each block is executed. For example, if the sample
time of a Video From Workspace block is 0.05, the Solver executes the code
behind this block, and every other block with this sample time, once every
0.05 second.

Video Duration and Simulation Time

The duration of the simulation is controlled by the Stop time parameter —
not the input video. If you want the simulation to run for the duration of the
input video, you must adjust the Stop time parameter. If your video is being
cropped, increase the parameter value. If your video is complete and the
display window is black, decrease the parameter value. To view the first NV
frames of your video, set the Stop time parameter to (N-1)*T,, where T is
the sample time of your source block.

You can access the Stop time parameter in the model window, as shown in
the following figure, or on the Solver pane of the Configuration dialog box.
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Acceleration Modes

The Simulink software offer Accelerator and Rapid Accelerator
simulation modes that remove much of the computational overhead required
by Simulink models. These modes compile target code of your model. Through
this method, the Simulink environment can achieve substantial performance
improvements for larger models. The performance gains are tied to the size
and complexity of your model. Therefore, large models that contain Video
and Image Processing Blockset blocks run faster in Rapid Accelerator or
Accelerator mode.

To change between Rapid Accelerator, Accelerator, and Normal mode, use
the drop-down list at the top of the model window.
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For more information on the accelerator modes in Simulink, see “Accelerating
Models” in the Simulink User’s Guide.

Strategies for Real-Time Video Processing

Video processing is computationally intensive, and the ability to perform
real-time video processing is affected by the following factors:

¢ Hardware capability

® Model complexity

® Model implementation

® Input data size

Optimizing Your Implementation

Optimizing your implementation is a crucial step toward real-time video
processing. The following tips can help improve the performance of your
model:

1-25



1 Getting Started

e Minimize the number of blocks in your model.

® Process only the regions of interest to reduce the input data size.

Use efficient algorithms or the simplest version of an algorithm that
achieves the desired result.

Use efficient block parameter settings. However, you need to decide
whether these settings best suit your algorithm. For example, the most
efficient block parameter settings might not yield the most accurate results.
You can find out more about individual block parameters and their effect
on performance by reviewing specific block reference pages.

The two following examples show settings that make each block’s operation
the least computationally expensive:

= Resize block — Interpolation method = Nearest neighbor

= Blocks that support fixed point — On the Fixed-Point tab, Overflow
mode = Wrap

® Choose data types carefully.
= Avoid data type conversions.

= Use the smallest data type necessary to represent your data to reduce
memory usage and accelerate data processing.

In simulation mode, models with floating-point data types run faster
than models with fixed-point data types. To speed up fixed-point models,
you must run them in accelerator mode. Simulink contains additional
code to process all fixed-point data types. This code affects simulation
performance. After you run your model in accelerator mode or generate
code for your target using Real-Time Workshop, the fixed-point data
types are specific to the choices you made for the fixed-point parameters.
Therefore, the fixed-point model and generated code run faster.

Developing Your Models

Use the following general process guidelines to develop real-time video
processing models to run on embedded targets. By optimizing the model at
each step, you improve its final performance.
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1 Create the initial model and optimize the implementation algorithm. Use
floating-point data types so that the model runs faster in simulation mode.
If you are working with a floating-point processor, go to step 3.

2 If you are working with a fixed-point processor, gradually change the model
data types to fixed point, and run the model after every modification.

During this process, you can use data type conversion blocks to isolate
the floating point sections of the model from the fixed-point sections. You
should see a performance improvement if you run the model in accelerator
mode.

3 Remove unnecessary sink blocks, including scopes, and blocks that log
data to files.

4 Compile the model for deployment on the embedded target.

Code Generation

The Video and Image Processing Blockset, Real-Time Workshop®, and
Real-Time Workshop® Embedded Coder™ software enable you to generate
code that you can use to implement your model for a practical application. For
instance, you can create an executable from your Simulink model to run on a
target chip. For more information, see “Understanding Code Generation” in
Signal Processing Blockset Getting Started Guide..

Shared Library Dependencies

For the blocks listed in the table below, copy the shared library files from the
machine where the blockset software is installed to a folder on the system
path of the destination machine.

Block Dependent library Product
file
To Multimedia File tommfile.dll Signal Processing
. Blockset™
SldirectShow.dll
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From Multimedia File | frommmfile.dll Signal Processing
SldirectShow.dll Blockset

To Video Display tovideodevice.dll Video and Image
SldirectShow.dll Processing Blockset
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Block Data Type Support

The Video and Image Processing Blockset Data Type Support Table is

now available through the Simulink model Help menu. The table provides
information about data type support and code generation coverage for all
Video and Image Processing Blockset blocks. Select Help > Block Support
Table> Video and Image Processing Blockset or Help > Block Support
Table > All Tables.

File Edit Wiew Simulaton Format Tools Help

D|Eﬂn§|%ﬁl|¢-¢ Using Simulink E@Iﬁ“ﬁ
Blocks -
Blocksets 4
Block Suppart Table » All Tables
k Shartcuts Simulink
S-Functions Communications Blockset

Signal Processing Blockset

D
Emas Video and Image Processing Blockset

Terms of Use...
Patents...

About Simulink

Ready [100%% [ [T=0.00 [ode4s

You can also type showvipblockdatatypetable at the MATLAB command
line to bring up the table.
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Image Credits

This table lists the copyright owners of the images used in the Video and
Image Processing Blockset documentation.

Source

cameraman

Copyright Massachusetts Institute of
Technology. Used with permission.

cell

Cancer cell from a rat’s prostate,
courtesy of Alan W. Partin, M.D.,
Ph.D., Johns Hopkins University
School of Medicine.

circuit

Micrograph of 16-bit A/D converter
circuit, courtesy of Steve Decker and
Shujaat Nadeem, MIT, 1993.

moon

Copyright Michael Myers. Used with
permission.
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Batch Processing Image Files

A common image processing task is to apply an image processing algorithm
to a series of files. In this example, you import a sequence of images from a
folder into the MATLAB workspace and display the sequence using the Video
and Image Processing Blockset software.

Note In this example, the image files are a set of 10 microscope images of rat
prostate cancer cells. These files are only the first 10 of 100 images acquired.

1 Specify the folder containing the images, and use this information to create
a list of the file names, as follows:

fileFolder = fullfile(matlabroot, 'toolbox',

'images', 'imdemos');

dirOutput = dir(fullfile(fileFolder, 'AT3_1m4_*.tif'));
fileNames {dirOutput.name}"’

2 View one of the images, using the following command sequence:

I = imread(fileNames{1});
imshow(I);
text(size(I,2),size(I,1)+15,
'Image files courtesy of Alan Partin',
'FontSize',7, 'HorizontalAlignment', 'right');
text(size(I,2),size(I,1)+25,
'dohns Hopkins University',
'FontSize',7, 'HorizontalAlignment', 'right');
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3 Use a for loop to create a variable that stores the entire image sequence.
You are going to use this variable to import the sequence into Simulink.

for i = 1:1length(fileNames)

my_video(:,:,i) = imread(fileNames{i});
end

4 Create a new Simulink model, and add to it the blocks shown in the
following table.
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Block Library Quantity

Video From Workspace | Video and Image 1
Processing Blockset >
Sources

Video Viewer Video and Image 1
Processing Blockset >
Sinks

5 Connect the blocks so your model looks similar to the following figure.

L=
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6 Use the Video From Workspace block to import the image sequence into
Simulink. Set the Signal parameter to my_video.

7 Use the Video Viewer block to view the image sequence. Accept the default
parameters.

8 Set the configuration parameters. Open the Configuration dialog box by
selecting Simulation > Configuration Parameters. On the Solver
pane, set the parameters as follows:

e Stop time = 10
* Type = Fixed-step

2-4



Batch Processing Image Files

e Solver =Discrete (no continuous states)

Because the Video From Workspace block’s Sample time parameter is set
to 1 and the Stop time parameter is set to 10, the Video Viewer block

displays 10 images before the simulation stops.

9 Run your model. You can view the image sequence in the Video Viewer
window.
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For more information on the blocks used in this example, see the Video
From Workspace and Video Viewer block reference pages. For additional
information about batch processing, see the Batch Processing Image Files
Using Distributed Computing demo in Image Processing Toolbox. You can
run this demo by typing ipexbatch at the MATLAB command prompt.
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Working with Live Video

Image Acquisition Toolbox provides functions for acquiring images and video
directly into MATLAB and Simulink from PC-compatible imaging hardware.
You can detect hardware automatically, configure hardware properties,
preview an acquisition, and acquire images and video.

See the live video processing demos to view demos that use the Image
Acquisition Toolbox together with Video and Image Processing blocks. To
see the full list of Video and Image Processing demos, type vipdemos at the
MATLAB command prompt.
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Working with Multimedia Files

In this section...

“Blocks That Support Multimedia Files” on page 2-8
“Importing and Viewing Multimedia Files” on page 2-8
“Exporting to Multimedia Files” on page 2-11
“Working with AVI Files” on page 2-14

“Working with Audio” on page 2-38

Blocks That Support Multimedia Files

The Video and Image Processing Blockset software contain blocks that you
can use to import and ex[prt multimedia files. These blocks include the From
Multimedia File block and the To Multimedia File block. If you are working
on a Windows platform, these blocks perform best on platforms with DirectX
Version 9.0 or later and Windows Media Version 9.0 or later. These blocks
also support code generation.

Importing and Viewing Multimedia Files

In this example, you use the From Multimedia File block to import a video
stream into a Simulink model and the To Video Display block to view it. This
procedure assumes you are working on a Windows platform:

1 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity

From Multimedia File | Video and Image 1
Processing Blockset >
Sources

To Video Display Video and Image 1
Processing Blockset >
Sinks




Working with Multimedia Files

2 Locate a multimedia file that you want to import into Simulink. If you
do not have access to a multimedia file, the Video and Image Processing
Blockset software has sample multimedia files you can use to complete
this procedure.

3 Use the From Multimedia File block to import the multimedia file into the
model. Double-click the From Multimedia File block:

¢ If you do not have your own multimedia file, enter vipmen.avi for the
File name parameter.

¢ [f the multimedia file is on your MATLAB path, enter the filename for
the File name parameter.

e If the file is not on your MATLAB path, use the Browse button to locate
the multimedia file.

* Set the Image signal parameter to Separate color signals.

By default, the Number of times to play file parameter is set to inf. The
model continues to play the file until the simulation stops.

4 Use the To Video Display block to view the multimedia file. Set the Image
signal parameter to Separate color signals.

5 Connect the blocks so your model looks similar to the following figure.

-ioix]
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6 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. On
the Solver pane, set the parameters as follows:

e Stop time = 20
e Type = Fixed-step
e Solver =Discrete (no continuous states)

7 Run your model.

View your video in the To Video Display window that automatically
appears when you start your simulation. This window closes as soon as
the simulation stops.

™ 1o video DEpRMI=TEY

Note The video that is displayed in the To Video Display window runs at
the frame rate that corresponds to the input sample time. To run the video
as fast as Simulink processes the video frames, use the Video Viewer block.

You have now imported and dobsisplayed a multimedia file in your Simulink
model. In “Exporting to Multimedia Files” on page 2-11, you manipulate your
video stream and export it to a multimedia file. For more information on the
blocks used in this example, see the From Multimedia File and To Video
Display block reference pages in the Video and Image Processing Blockset
Reference. To listen to audio associated with an AVI file, use the To Audio
Device block in Signal Processing Blockset software.
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Exporting to Multimedia Files

The Video and Image Processing Blockset blocks enable you to export video
data from your Simulink model. In this section, you use the To Multimedia
File block to export an multimedia file from your model.

1 If the model you created in “Importing and Viewing Multimedia Files” on
page 2-8 is not open on your desktop, you can open an equivalent model

by typing

doc_export2

at the MATLAB command prompt.

E! doc_export2
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2 Click-and-drag the following blocks into your model.

Block Library Quantity
To Multimedia File Video and Image 1
Processing Blockset >
Sinks
Gain Simulink > Math 3

Operations

3 Use the Gain blocks to increase the red, green, and blue values of the video
stream. This increases the contrast of the video. Set the block parameters

as follows:
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® Main pane, Gain = 1.2
e Signal Attributes pane, Output data type = Inherit: Same as
input
4 Use the To Multimedia File block to export the video to a multimedia file.
Set the block parameters as follows:
¢ Output file name = my_output.avi
* Write = Video only
* Image signal = Separate color signals

E Sink Block Parameters: To Multimedia File x|

— To Multimedia File

wirtes video frames® and/or audio samples to a multimedia file. Audio and video
compressors are also available to compress audio and/or video streams in the autput
file. If the specified cutput file exists, it will be ovenaritten.

“Yideo functionality requires a Video and Image Processing Blockzet icensze.

Ol for use on Windows platforms,

—Parameters
Cutput file name: |my_u:uutput.avi Browse... |
\A-"lite:l Wideo anly ;I
Wideo compressnl:l More [uncompresszed) ;I
Image signal:l Separate color gsignalz ;I

Cancel Help | Apply |

5 Connect the blocks as shown in the following figure. You might need to
resize some blocks to do so.
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You are now ready to set your block parameters by double-clicking the
blocks, modifying the block parameter values, and clicking OK.

6 If you have not already done so, set the configuration parameters. Open the
Configuration dialog box by selecting Configuration Parameters from
the Simulation menu. On the Solver pane, set the parameters as follows:

e Stop time = 20
e Type = Fixed-step

e Solver =Discrete (no continuous states)
7 Run your model.

You can view your video in the To Video Display window. By increasing the
red, green, and blue color values, you increased the contrast of the video.
The To Multimedia File block exports the video data from the Simulink
model to a multimedia file that it creates in your current folder.
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You have now manipulated your video stream and exported it from a Simulink
model to a multimedia file. For more information, see the To Multimedia File
block reference page in the Video and Image Processing Blockset Reference.

Working with AVI Files

* “Importing and Viewing AVI Files” on page 2-14

* “Exporting to AVI Files” on page 2-18

e “Annotating AVI Files with Video Frame Numbers” on page 2-22
* “Annotating AVI Files at Two Separate Locations” on page 2-26
e “Saving Portions of an AVI File to Separate Files” on page 2-30

Importing and Viewing AVI Files

Before you can analyze or operate on your data, you must import it into
your Simulink model. Blocks from the Sources library, such as the From
Multimedia File block, can help you with this type of task.

In this section, you use the From Multimedia File block to import video from
an AVI file into your model and the Video Viewer block to view it:

1 Create a new Simulink model, and add to it the blocks shown in the
following table.
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Block Library Quantity

From Multimedia File | Video and Image Processing 1
Blockset > Sources

Video Viewer Video and Image Processing 1
Blockset > Sinks

2 Use the From Multimedia File block to import an AVI file into the model.
Double-click the From Multimedia File block. The Video and Image
Processing Blockset software has sample AVI files you can use to complete
this procedure.

¢ [f you do not have your own AVI file, enter barcodes.avi for the File
name parameter.

o [f the AVI file is on your MATLAB path, enter the AVI filename for
the File name parameter.

e If the file is not on your MATLAB path, use the Browse button to locate
the AVI filename.

* Image signal = Separate color signals

By default, the Number of times to play file parameter is set to inf. The
model continues to play the file until the simulation stops.

3 Use the Video Viewer block to view the AVI file. Click the File menu of
the Video Viewer GUI to set the Image signal parameter to Separate
color signals.

4 Connect the blocks so your model looks similar to the following figure.
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5 Set the configuration parameters. Open the Configuration dialog box by
selecting Simulation > Configuration Parameters. Set the parameters
as follows:

¢ Solver pane, Stop time = 20
® Solver pane, Type = Fixed-step
¢ Solver pane, Solver = Discrete (no continuous states)

6 Run your model.

View your video in the Video Viewer window that automatically appears
when you start your simulation.
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Note The video that is displayed in the Video Viewer window runs as fast
as Simulink processes the video frames. If you are on a Windows platform
and you want to run the video at the frame rate that corresponds to the
input sample time, use the To Video Display block.

You have now imported and displayed video data in your Simulink model. In
“Exporting to AVI Files” on page 2-18, you manipulate your video stream
and export it to an AVI file. For more information on the blocks used in this
example, see the From Multimedia File and Video Viewer block reference
pages in the Video and Image Processing Blockset Reference. To listen to
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audio associated with an AVI file, use the To Audio Device block in Signal
Processing Blockset software.

Note The Video Viewer block is supported on all platforms, but it does not
support code generation. If you are on a Windows platform, you can use
the To Video Display block to display video data. This block supports code
generation. For more information, see the To Video Display block reference
page in the Video and Image Processing Blockset Reference.

Exporting to AVI Files

The Video and Image Processing Blockset blocks enables you to export video
data from your Simulink model. In the following procedure, you use the To
Multimedia File block to export video data from your model into an AVI file:

1 If the model you created in “Importing and Viewing AVI Files” on page 2-14
is not open on your desktop, open an equivalent model by typing

doc_export
at the MATLAB command prompt.
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2 Click-and-drag the blocks shown on the following table into your model.
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Block Library Quantity

To Multimedia File Video and Image Processing 1
Blockset > Sinks

Gain Simulink > Math Operations 2

3 Change the inputs to the To Multimedia File block. Set the block

parameters as follows:

* Write = Video only

¢ Image signal = Separate color signals

4 Connect the blocks as shown in the following figure. You might need to
resize some blocks to do so.
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5 Use the Gain block to change the green values of the video stream. Set the

block parameters as follows:
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® Main pane, Gain = 0.3
¢ Signal Attributes pane, Output data type = Inherit:Same as input

6 Use the Gainl block to change the blue values of the video stream. Set the
block parameters as follows:

¢ Main pane, Gain = 1.5

¢ Signal Attributes pane, Output data type = Inherit:Same as input

7 Use the To Multimedia File block to export the video to an AVI file. Set
the File name parameter to my_test_file.avi.

E! Sink Block Parameters: To Multimedia File x|

— To Multimedia File

Writes video frames and/or audio samples to a multimedia file, On Windows, audio
and video compressors are also available to compress audio and/for video streams
in the output file, If the specified output file exists, it will be averwritten,

Video functionality requires a Video and Image Processing Blockset license,

—Parameters
Filename: I H:'\DocumentsSimulink Models'my_test_file, avil Browse... |
Write: I'-a'iu:le-:n anly ;I
Video compressar; IHDnE (uncompressed) ;I
Image signal: ISEparate color signals j

oK Cancel Help Apply

8 If you have not already done so, set the configuration parameters. Open
the Configuration dialog box by selecting Simulation > Configuration
Parameters. Set the parameters as follows:

¢ Solver pane, Stop time = 20

¢ Solver pane, Type = Fixed-step
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® Solver pane, Solver = Discrete (no continuous states)
9 Run your model.

You can view your video in the Video Viewer window. The To Multimedia
File block exports the video data from the Simulink model to an AVI file
that it creates in your current folder.
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You have now manipulated your video stream and exported it from a Simulink
model to an AVI file. For more information, see the To Multimedia File block
reference page in the Video and Image Processing Blockset Reference.
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Annotating AVI Files with Video Frame Numbers

You can use the Insert Text block to overlay text on video stream. In this
example, you add a running count of the number of video frames to a video.

1 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity

From Multimedia File | Video and Image Processing 1
Blockset > Sources

Insert Text Video and Image Processing 1
Blockset > Text & Graphics

Video Viewer Video and Image Processing 2
Blockset > Sinks

2 Position the blocks as shown in the following figure.

=

File Edit Wiew Simulation Format Tools  Help

D& B2 <=4 Q] r =m0 [vomad |

Image ‘.f_ideo
wip e n.ai Wiewer
Wi A20x180, Image
20 fp=
Wideo Viewer

Frorm muktiredia Fike

. Wideo
Teoxt! Irnage Viewar
Insert Text Wideo Viewerl
Ready [100% [ [ |odeds 4

3 Use the From Multimedia File block to import the video into the Simulink
model. Set the Image color space parameter to Intensity.
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4 Open the Surveillance Recording demo by typing

vipsurveillance

at the MATLAB command prompt.

5 Click-and-drag the Frame Counter block from the demo model into your
model. This block counts the number of frames in an input video.

6 Use the Insert Text block to annotate the video stream with a running
frame count. Set the block parameters as follows:

® Main pane, Text = [ 'Frame count' sprintf('\n') 'Source frame:
%d']

¢ Main pane, Location = [85 2]

¢ Main pane, Color value = 1

* Font pane, Font face = LucindaTypewriterRegular

By setting the Text parameter to [ 'Frame count' sprintf('\n')
'Source frame: %d'], you are asking the block to print Frame count on
one line and theSource frame: on a new line. Because you specified %d,
an ANSI C printf-style format specification, the Variables port appears on
the block. The block takes the port input (it is expecting a decimal) and
substitutes it for the %d in the string. You used the Location parameter to
specify where to print the text. In this case, the location is 85 rows down
and 2 columns over from the top left corner of the image.

7 Use the Video Viewer blocks to view the original and annotated videos.
Accept the default parameters.

8 Connect the blocks as shown in the following figure.
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9 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

¢ Solver pane, Stop time = inf
® Solver pane, Type = Fixed-step
e Solver pane, Solver = Discrete (no continuous states)

10 Run the model.

The original video appears in the Video Viewer window.
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File Tools View Playback Help

=10 i

|
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100%
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Pauzed [:420:1 60 T=43.033

The annotated video appears in the Video Viewerl window.
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Framescotht
Source frame: 12928

Paused [:120:1 60 T=

435.000
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You have now added descriptive text to a video stream. For more information,
see the Insert Text block reference page in the Video and Image Processing
Blockset Reference. For related information, see the Draw Shapes and Draw
Markers block reference pages.

Annotating AVI Files at Two Separate Locations

You can use the Insert Text block to overlay text on a video stream at two
separate locations in the video frame.

1 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity

From Multimedia File | Video and Image Processing 1
Blockset > Sources

Insert Text Video and Image Processing 1
Blockset > Text & Graphics

Video Viewer Video and Image Processing 1
Blockset > Sinks

Constant Simulink > Sources 1

2 Position the blocks as shown in the following figure.
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_ioix

File Edit VYiew Simulation Format Tools  Help

D|D”E§|%E|<}==ﬁ>{f|92|b II'ID.D INormaI j|

wiprnen. i YWideo
V120160,  Image Tt Image Viewear
30 fp=s
Frorn hiufirediz File Insert Text Video Viewer
1
Constant
Ready [100% | | |odeds G

3 Use the From Multimedia File block to import the video stream into the
Simulink model. Accept the default parameters.

4 Use the Insert Text block to annotate the video with two text strings. Set
the block parameters as follows:

® Main pane, Text = 'Text position: Row %d and Column %d'

® Main pane, Location = [[5 10]' [80 10]']

By setting the Text parameter to 'Text position: Row %d and Column
%d', you are asking the block to replace each conversion specification

(%d) with a decimal input to the Variables port. You used the Location
parameter to specify where to print each text string. In this case, the block
places the top-left corner of the text box that surrounds the first text string
5 rows down and 10 rows over from the top left corner of the image. The
block places the second text string 80 rows down and 10 rows over.

5 Use the Constant block to specify the decimal values input into the Insert
Text block’s Variables port. Because the conversion specification is %d, the
values must be an integer data type. Set the block parameters as follows:

® Main pane, Constant value =[[5 10]' [80 10]']
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® Main pane, clear the Interpret vector parameters as 1-D check box.

e Signal Attributes pane, Output data type = uint8

The Insert Text block substitutes the values from the first column of the
Constant value parameter into the first text string and the values from
the second column into the second text string.

6 Use the Video Viewer blocks to view the annotated image. Accept the
default parameters.

7 Connect the blocks as shown in the following figure.

ol
File Edit Wiew Simulakion  Format  Tools  Help
DSEH& R e 4 |(2ar oo [ion |5
wip e n.ai
Vo 120x160, Image - Image
20 fps Text pos... | image \\;ri:::r
From hutimedia Fie W Vanables
Insart Text Wideo Wiewer
[[5 10]' [80 1071
Constant
Ready [100% | | |FixedstepDiscrete v

8 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time = inf
® Solver pane, Type = Fixed-step

® Solver pane, Solver = Discrete (no continuous states)
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9 Run the model.

The annotated video appears in the Video Viewer window.

(o]

File Tools Wiew Playback Help b
B0 8|&a |
m | E

Pauszed [120x160 T=81 800

Alternatively, you can input two string values at the Variables port.

10 On the Insert Text block dialog box, set the Text parameter to'%s region
of interest'.

You are asking the block to replace the %s conversion specification with a
string input to the Variables port.

11 Use the Constant block to specify the strings to substitute into the first
and second text strings. Because the conversion specification is %s, the
values must be 8-bit unsigned integer data types. Set the Constant value
parameter to [uint8('First') 0 uint8('Second')].

12 Run the model.

The annotated video appears in the Video Viewer window.
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You have now added descriptive text to a video stream. For more information,
see the Insert Text block reference page in the Video and Image Processing
Blockset Reference.

Saving Portions of an AVI File to Separate Files

In this section, you use To Multimedia File and Enabled Subsystem blocks to
save portions of one AVI file to three separate AVI files.

1 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity

From Multimedia File | Video and Image Processing 1
Blockset > Sources

Insert Text Video and Image Processing 1
Blockset > Text & Graphics

Enabled Subsystem Simulink > Ports & Subsystems 3
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Block Library Quantity

To Multimedia File Video and Image Processing 3
Blockset > Sinks

Counter Signal Processing Blockset > 1
Signal Management > Switches
and Counters

Compare To Constant | Simulink > Logic and Bit 5
Operations

Logical Operator Simulink > Logic and Bit 1
Operations

Stop Simulation Simulink > Sinks 1

2 Place the blocks so that your model looks similar to the one in the following

figure.
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3 Use the From Multimedia File block to import an AVI file into your model.

Set the parameters as follows:

¢ Uncheck Inherit sample time from file checkbox

® Set Desired sample time parameter = 1/30

4 Use the Insert Text block to annotate the video stream with the frame
numbers. Set the parameters as follows:

e Text = 'Frame %d'

* Location=[10 10]

e Color=1[0 1 0]
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The block writes the frame number in green in the upper-left corner of the
output video stream.

5 Double-click each Enabled Subsystem block, and click-and-drag one of the
To Multimedia File blocks into it.

6 Inside each Enabled Subsystem, connect the blocks so that your subsystem
looks similar to the one in the following figure.

5] untitled /Enabled Subsystem * =10 x|
File Edit Wiew Simulation Formak  Tools  Help

NEEHE 2 (e ae

(1 F———{Image

In1 output.aoi

Audia

To hiuktiredia Filke

FlioDw | | |ode45 w

7 Use the To Multimedia File blocks to send the video stream to three
separate AVI files. Set the block parameters as follows:

¢ Output file name = outputi.avi, output2.avi, and output3.avi,
respectively

® Write = Video only

Each enabled subsystem should now look similar to the subsystem shown
in the following figure.

2-33



2 Importing and Exporting Images and Video

[=]untitled,/Enabled Subsystem * O] x|

File Edit Wiew Simulation Format Tools  Help

DEHE| R[4 |22

Image outputd.awvi

In1

To Mukirmedia. Fike

Fl1onw. | | |nde4s w

8 Use the Counter block to count the number of video frames. You use this
information to specify which frames are sent to which file. Set the block
parameters as follows:

¢ Count event = Free running

¢ Initial count = 1

® OQutput = Count

® (Clear the Reset input check box.
* Sample time = 1/30

® Count data type = uint16

9 Use the Compare to Constant block to send frames 1 to 9 to the first AVI
file. Set the block parameters as follows:

* Operator = <

¢ Constant value = 10
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10 Use the Compare to Constantl and Compare to Constant2 blocks to send
frames 10 to 19 to the second AVI file. Set the Compare to Constantl block
parameters as follows:

e Operator = >=

* Constant value = 10

Set the Compare to Constant2 block parameters as follows:
¢ Operator = <

e Constant value = 20

11 Use the Compare to Constant3 block to send frames 20 to 30 to the third
AVI file. Set the block parameters as follows:

¢ Operator = >=

¢ Constant value = 20

12 Use the Compare to Constant4 block to stop the simulation when the video
reaches frame 30. Set the block parameters as follows:

e Operator = ==
* Constant value = 30

¢ Qutput data type mode = boolean

13 Connect the blocks so that your model resembles the one in the following
figure.
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14 Set the configuration parameters. Open the Configuration dialog box by
selecting Simulation > Configuration Parameters. Set the parameters

as follows:

® Solver pane, Type = Fixed-step

® Solver pane, Solver = Discrete (no continuous states)

15 Run your model.

The model saves the three output AVI files in your current folder.
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16 View the resulting files by typing the following commands at the MATLAB
command prompt:

mplay outputi.avi
mplay output2.avi
mplay output3.avi

Then, press the Play button on the MPlay GUI.

. MPlay [3] - File: output3.avi - O] x|

File Tools Wew Playback Help
0 ﬁrﬁ@||ﬂ|@l@{{“§' 100%

MHwa m oo e

Stopped |RGE:1 20160 [100% (30 fps) 11711

You have now sent portions of an AVI file to three separate AVI files using
an Enabled Subsystem block, a To Multimedia File block, and a trigger
signal. For more information on the blocks used in this example, see the

From Multimedia File, Insert Text, Enabled Subsystem, and To Multimedia
File block reference pages.
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Working with Audio

In this example, you use the From Multimedia File block to import a video
stream into a Simulink model. You also use Signal Processing Blockset
software From Wave File block to import an audio stream into the model.
Then you write this audio and video to a single file using the To Multimedia

File block.

This procedure assumes you are working on a Windows platform:

1 Create a new Simulink model, and add to it the blocks shown in the

following table.

Block Library Quantity
From Multimedia File | Video and Image 1
Processing Blockset >
Sources
From Wave File Signal Processing 1
Blockset > Signal
Processing Sources
To Multimedia File Video and Image 1

Processing Blockset >
Sinks

2 Connect the blocks so your model looks similar to the following figure.
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3 Use the From Multimedia File block to import a multimedia file into
the model. Deselect the Inherit sample time from file check box.
(Deselecting the checkbox enables Desired sample time parameter.)
Accept the following default parameters.
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E! Source Block Parameters: From Multimedia File x|
— Fram Multimedia File =]
On Windows, reads video frames and/or audio zamples from a compreszed or
uncompressed multimedia file. Multimedia files can contain audio, video, or audio and
wideo data.
On hon-windows platfarms, reads video frames and/or audio samples from an
uncompressed A file.
Wideno functionality requirez a Video and Image Processing Blockzet license.
E | Data Types I
— Parameter
File narme: Ivipmen.avi Browsze... |
[ Inherit zample time from file Degired zample time; |1 430
Mumber of timesz to plag file: |inf
— Olutput
[ Output end-of-file indicatar
Image color space:IF!GB VI Image gignal: IDne multidimengional gignal ;I |
hd|
Ok I Cancel | Help

The From Multimedia File block inherits its sample time from vipmen.avi.
For video signals, the sample time is equivalent to the frame period.
Because this file’s frame rate is 30 frames per second (fps) and the frame
period is defined as 1/frame rate, the frame period of this block is 0.0333
seconds per frame.

Use the From Wave File block to import an audio file into the model. To
calculate the output frame size, divide the frequency of the audio signal
(22050 samples per second) by the frame rate (which is approximately 30
frames per second) to get 735 samples per frame. Set the Samples per
output frame parameter to 735.
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E Source Block Parameters: From Wave File x|

r— From “Wave File [maszk] [link]

Reads audio data zamples from a standard Windows PCM format oway' audio file,
When looping, enter number of times to play the file's data, or enter "inf'"* to loop
indefinitely.

Only for uze with Windows platforms,

— Parameter.

File narne:

Ispeech_dft. way

Samples per output frame:
{735

Mirimumn number of zamples for each read from file:
|256

D ata type: Idnuble LI
[ Loop

Murnber of times to play file:
Ji

Samples restart|immediately after [ast sample ;I

[ Output start-of-file indicator
[ Dutput end-of-file indicator

ok I Cancel Help

The frame period of the audio signal must match the frame period of the
video signals, which is 0.0333 seconds per frame. Since the frame period
is also defined as the frame size divided by frequency, you can calculate
the frame period of the audio signal by dividing the frame size of the
audio signal (735 samples per frame) by the frequency (22050 samples
per second) to get 0.0333 seconds per frame. Alternatively, you can verify
that the frame period of the audio and video signals is the same using a
Simulink Probe block.

5 Use the To Multimedia File to output the audio and video signals to a
single multimedia file. Select Video and audio for the Write parameter
and One multidimensional signal for the Image signal parameter.
Accept the other default parameters.
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E Sink Block Parameters: To Multimedia Filel x|

— To Multimedia File [}

Wites wideo frames and/or audio zamples to a multimedia file. On windows, audio and
viden compressorz are aleo available to compress audio and/or video streams in the
output file. If the specified output file exists, it will be ovenaritien.

Yiden functionality requires a Video and Image Proceszing Blockset licenze.

— Parameter:

Output file name: || Browse. ..

ke [Wideo and audio
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0K I Cancel Help | Apply |
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6 Set the configuration parameters. Open the Configuration dialog box by
selecting Simulation > Configuration Parameters. On the Solver
pane, set the parameters as follows:

e Stop time = 10
* Type = Fixed-step

e Solver =Discrete (no continuous states)

7 Run your model. The model creates a multimedia file called output.avi in
your current folder.

8 Play the multimedia file using a media player. The original video file now
has an audio component to it.

You have now combined audio and video information into a single file using
the To Multimedia File block. For more information, see the To Multimedia

File block reference page in the Video and Image Processing Blockset
Reference.
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Working with MATLAB Workspace Variables

How to Import MATLAB Workspace Variables

You can import data from the MATLAB workspace using the Video From
Workspace block, which is created specifically for this task.

E! Source Block Parameters: ¥ideo From Worksp x|

— Widea Fram ‘Warkzpace [mazk] [link]

Dutputs videa frames fram the MATLAR workspace at successive zample times.

[ the wideno signal iz a M-by-k-by-T waorkspace armay, the block outputs an intensity
video zignal, where M and M are the number of rows and columnz in a zingle video
frame, and T iz the number of frames in the video zignal.

If the wideao zignal iz a M-bp-k-by-C-bp-T workzpace aray, the block outputz a colar
video signal, where M and M are the number of rows and columnz in a single videa
frame, C iz the number of outputs from the block, and T iz the number of framesz in the
video strean.

— Parameter

Signal:
[rand(32.32.3.5)

S ample tirme:
[1

Faorm output after final walue by: IE_I,In:Iiu: repetition

L] L]

Image zignal: | One multidimenzsional signal

(] Cancel Help

Use the Signal parameter to specify the MATLAB workspace variable from
which to read. For more information about how to use this block, see the
Video From Workspace block reference page.
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Viewing Video

* “Viewing Video Files” on page 3-2
* “Viewing Video Signals in Simulink” on page 3-3

* “Viewing Video File Frames” on page 3-22



3 Viewing Video

Viewing Video Files

The Video and Image Processing Blockset provides three video viewer
applications to accommodate your specific requirements. This table
summarizes the intended use for these viewers.

Viewer Intended Use

Video Viewer A full featured viewer for your Simulink model.
The Video Viewer includes simulation controls and
analysis tools.

To Video Display A Windows® only lightweight, higher performance
simple display. This block also generates code.

mplay View video signals in Simulink models without adding
blocks to your model or view signal from the MATLAB
workspace or directly from a file.
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Viewing Video Signals in Simulink

In this section...

“Using the Video Viewer Block” on page 3-3
“Using the To Video Display Block” on page 3-3
“Using the MPlay GUI” on page 3-3

Using the Video Viewer Block

Use the Video Viewer block when you require a wired-in video display with
simulation controls in your Simulink model. The Video Viewer block provides
simulation control buttons directly from the GUI. The block integrates play,
pause, and step features while running the model and also provides video
analysis tools such as pixel region viewer.

For more information about the Video Viewer block, see the Video Viewer
block reference page in the Video and Image Processing Blockset Reference.

Using the To Video Display Block

Use the To Video Display block in your Simulink model as a simple display
viewer designed for optimal performance. This block supports code generation
for the Windows platform.

For more information about the To Video Display block, see the To Video
Display block reference page in the Video and Image Processing Blockset
Reference.

Using the MPlay GUI

The MPlay GUI enables you to view video signals in Simulink models without
adding blocks to your model. You can also view videos represented as
variables in the MATLAB workspace.

You can open several instances of the MPlay GUI simultaneously to view
multiple video data sources at once. You can also dock these MPlay GUIs in
the MATLAB desktop. Use the figure arrangement buttons in the upper-right
corner of the Sinks window to control the placement of the docked GUIs.
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For further information on using the MPlay GUI, see the following topics:

¢ “Connecting MPlay to Your Simulink Model” on page 3-4
e “MPlay GUI Interface” on page 3-6

For more information about the MPlay GUI, see the mplay function reference
page.

Connecting MPlay to Your Simulink Model

Set Simulink simulation mode to Normal to use mplay . MPlay does not work
when you use “Acceleration Modes” on page 1-24.

The following procedure shows you how to use the MPlay GUI to view a
Simulink signal:

1 Open a Simulink model. At the MATLAB command prompt, type

vipmplaytut

E!vipmplaytut =10l |

File Edit ‘Yiew Simulation Format Tools Help

MPlay: Working with Simulink

&-bit RGE &-bit RGE Single-preision RGE bus after RGE companant
component signalks sianal bus RSB signal bus mtation =signalks
R Source-R
L
_________________ 5
wipmen.bin G SouesG | Gonvert Image | Eoume
o single Fotate e e oo >
B Source-B - Angle WideoBus ~Zource G
RSE Yideo Fiotate woume B
o Bus Selkector
3 Rotation
-
Ready [100% [ [ |Fixedstepbiscrete v

2 Open an MPlay GUI by typing mplay on the MATLAB command line.
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3 Run the model.
4 Select the signal line you want to view. For example, select the bus signal
coming out of the Rotate block.

5 On the MPlay GUI, click Connect to Simulink Signal GUI element, E@

The video appears in the MPlay window.

=) MPlay [1] - Simulink: Rotate -0 x|
|

File Tools View Playback Help
=l

D& | 8O | & & | 5]
m oD@ S|l

RGE:200x200  T=203.600

Paused

6 Change to floating-scope mode by clicking the persistent connect GUI

element, ET— button.
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3-6

7 Experiment with selecting different signals and viewing them in the
MPlay window. You can also use multiple MPlay GUIs to display different

Simulink signals.

Note During code generation, Real-Time Workshop does not generate code

for the MPlay GUI.

MPlay GUI Interface

The following figure shows the MPlay GUI containing an image sequence.

. MPlay [1] - File: viptrain.avi 10l =l
File Tools Wwiew Playback Help L
Toolbar — D|D”%U§||o|@law IIDD% -
Playback CH WA E =D e
toolbar
Video
frames

RGE:240x360  100% (30 fps) 16 626

Video
Status

Frame size
Type of video Frame
(lor RGB)
Current frame/Total frames
NOTE: + and - indicate
Percentage playback direction.

of frame rate
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The following sections provide descriptions of the MPlay GUI toolbar buttons
and equivalent menu options.

Toolbar Buttons

GUI | Menu Shortcut Keys Description
Equivalent and Accelerators

[ File > New Ctrl+N Open a new MPlay GUI.

MPla
y
= File > Open Ctrl+O Connect to a video file.
i File > Ctrl+I Connect to a variable from the
Import from base MATLAB workspace.
Workspace
@ File > Connect to a Simulink signal.
Connect to
Simulink
Signal
@ File > Export | Ctrl+E Send the current video
to Image Tool frame to the Image Tool.
For more information, see
“Using the Image Tool to
Explore Images” in the
Image Processing Toolbox
documentation.
The Image Tool only knows
the frame is an intensity
image if the colormap of
the frame is grayscale
(gray(256)). Otherwise, the
Image Tool assumes that the
frame is an indexed image
and disables the Adjust
Contrast button.

Tools > Video | V View information about the

Information

video data source.
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3-8

GUI | Menu Shortcut Keys Description
Equivalent and Accelerators
Tools > Pixel | N/A Open the Pixel Region
= | Region tool. For more information
about this tool, see the
Image Processing Toolbox
documentation.
@l Tools > Zoom | N/A Zoom in on the video display.
In
=] Tools > Zoom | N/A Zoom out of the video display.
Out
{m;. Tools > Pan N/A Move the image displayed in
the GUL
Tools > N/A Scale video to fit GUI size
Maintain Fit automatically. Toggle the
to Window button on or off.
N/A Enlarge or shrink the video

|11I:I%

N/A vl

display. This option is
available if you do not select
the Maintain Fit to Window
button.

Playback Toolbar — Workspace and File Sources

GUI | Menu Shortcut Keys Description
Equivalent and Accelerators
M Playback > F, Home Go to the first frame of the
Go to First video.
Playback > Up arrow Jump back ten frames.
44 )
Rewind
n Playback > Left arrow, Page Step back one frame.
Step Back Up
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GUI | Menu Shortcut Keys Description
Equivalent and Accelerators
= Playback > S Stop the video.
____ | Stop
- Playback > P, Space bar Play the video.
Play
Playback > P, Space bar Pause the video. This button
] .
Pause appears only when the video
is playing.
n» Playback Right arrow, Page | Step forward one frame.
> Step Down
Forward
Playback > Down arrow Jump forward ten frames.
M
Fast Forward
Playback > L, End Go to the last frame of the
M .
Go to Last video.
~ | Playback > J Jump to a specific frame.
=7 | Jump to
¢ Playback > R Repeated video playback.
Playback
Modes >
Repeat
— | Playback > A Play the video forward.
Playback
Modes >

Forward play
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GUI

Menu
Equivalent

Shortcut Keys
and Accelerators

Description

Playback >
Playback
Modes >
Backwardplay

A

Play the video backward.

1

Playback >
Playback
Modes >
AutoReverse

play

Play the video forward and
backward.

Playback Toolbar — Simulink Sources

GUI | Menu Shortcut Keys Description
Equivalent and Accelerators
n Playback > S Stop the video. This button
| Stop also controls the Simulink
model.
P Playback > P, Space bar Play the video. This button
Start also controls the Simulink
model.
m Playback > P, Space bar Pause the video. This button
Pause also controls the Simulink
model and appears only when
the video is playing.
I» Playback Right arrow, Page | Step forward one frame.
> Step Down This button also controls the
Forward Simulink model.
: aybac 1ick this button to freeze the
Playback N/A Click this b fi h
> Simulink display in the MPlay window.
Snapshot
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GUI | Menu Shortcut Keys Description
Equivalent and Accelerators

3 Playback > Ctrl+L In the model window,
Highlight highlight the Simulink
Simulink signal the MPlay GUI is
Signal displaying.

ET‘ Playback N/A Indicates persistent Simulink
> Floating connection. In this mode, the
Signal MPlay GUI always associates
Connection with the Simulink signal you
(not selected) selected before you clicked

the Connect to Simulink
Signal button.

é:l’_‘ Playback N/A Indicates floating Simulink
> Floating connection. In this mode, you
Signal can click different signals in
Connection the model, and the MPlay
(selected) GUI displays them. You can

use only one MPlay GUI in
floating-scope mode at a time.
Configuration

The MPlay Configuration dialog box enables you to change the behavior and
appearance of the GUI as well as the behavior of the playback shortcut keys.

® To open the Configuration dialog box, select File > Configuration
Set > Edit.

e To save the configuration settings for future use, select

File > Configuration Set > Save as.

Note By default, the MPlay GUI uses the configuration settings from the
file mplay.cfg. Create a backup copy of the file to store your configuration
settings.
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® To load a preexisting configuration set, select File > Configuration

Set > Load.

Configuration Core Pane

The Core pane controls the graphic user interface (GUI) general and source

settings.

= ):MPlay [1] - Configuration

Core | Sources I Yisuals I Tu:u:ulsl

Name Description
General I Scope user interface settings
Source LI Cornmon source setkings

Options ... |

Ik Cancel

Al

General Ul

Click General UI, and then select the Options button to open the General
UI Options dialog box.

+ ): MPlay [1] - CorexGeneral UI Options x|

—General UL Options

[ Display the full source path in the title bar

Cpen message log: |for warn/faill messages - |

oK Cancel | Apply

If you select the Display the full source path in the title bar check box,

the full Simulink path appears in the title bar. Otherwise, the title bar

displays a shortened name.
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Use the Message log opens when parameter to control when the Message
log window opens. You can use this window to debug issues with video
playback. Your choices are for any new messages, for warn/fail
messages, only for fail messages, or manually.

Source Ul
Click Source Ul, and then click the Options button to open the Source Ul
Options dialog box.

= ): MPlay - CorezSource UI Options x|

Source UI Options

¥ Keyboard commands respect source playback modes

Recently used sources list; |3 entries

oK Cancel Apply

If you select the Keyboard commands respect playback modes check
box, the keyboard shortcut keys behave in response to the playback mode
you selected.

Using the Keyboard commands respect playback modes
Open and play a video using MPlay.
1 Select the Keyboard commands respect playback modes check box.

2 Select the Backward playback button.

¢ Using the right keyboard arrow key moves the video backward, and
using the left keyboard arrow key moves the video forward.

e With MPlay set to play backwards, the keyboard “forward” performs
“forward with the direction the video is playing”.

To disconnect the keyboard behavior from the MPlay playback settings, clear
the check box.
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Use the Recently used sources list parameter to control the number of
sources you see in the

Configuration Sources Pane
The Sources pane contains the GUI options that relate to connecting to

different sources. Select the Enabled check box next to each source type to
specify to which type of source you want to connect the GUI.

«):MPlay [1] - Configuration x|

Core Sources | Visuals I Tools I

Enabled |Mame Description
I Simulink Connect ko Simulink signal
3 File Connect ko file
v Workspace Import Fram MATLAE workspace

Options ... | Ok Cancel Apply

Click File, and then click the Options button to open the Sources:File
Options dialog box.

= ): MPlay - Sources:File Options |

File Source Options

Default open file path: IH: i

(0]4 Cancel Apply

Use the Default open file path parameter to control the folder that is
displayed in the Connect to File dialog box. The Connect to File dialog box
becomes available when you select File > Open.
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Click Simulink, and then click the Options button to open the

Sources:Simulink Options dialog box.

= ): MPlay - Sources:Simulink Options

Simulink Source Options

¥ Load Simulink model if not open

Ok

Cancel

Apply

You can have the Simulink model associated with an MPlay GUI to open with
MPlay. To do so, select the Load Simulink model if not open check box.

Configuration Visuals Pane

The Visuals pane contains the name of the visual type and its description.

= ):MPlay [1] - Configuration

Core I Sources

Yisuals | T|:||:||5|

Name

Description

Yiden

Viden visualization

opkiens ... |

(4 Zancel Apply

Configuration Tools Pane

The Tools pane contains the tools that are available on the MPlay GUI. Select
the Enabled check box next to the tool name to specify which tools to include

on the GUI
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= ):MPlay [1] - Configuration

Core I Sources I Yisuals

Toals

Enabled |MName Description
2 Image Tool Display the frame in Image Tool
2 Pixel Reqion Displaw pixel infarmation For a region in the frame
2 Image Mavigation Tc|Pan ar zoom khe frame
2 Instrumentation Set| Save o load mulkiple scope settings

Options ... |

Ik Cancel Apply

Click Image Tool, and then click the Options button to open the Image
Tool Options dialog box.

= ). MPlay - Tools:Image Tool Options x|

Export to Image Tool Options

¥ Cpen new Image Tool window for each export

Ok

Cancel Apply

Select the Open new Image Tool window for export check box if you want
to send each video frame to a different session of Image Tool.

Pixel Region
Select the Pixel Region check box to display and enable the pixel region GUI
button. For more information on working with pixel regions, see Getting
Information about the Pixels in an Image.

Image Navigation Tools

Select the Image Navigation Tools check box to enable the pan-and-zoom

GUI button.

Instrumentation Set
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Select the Instrumentation Set check box to enable the option to load and
save viewer settings. The option appears in the File menu.

Video Information

The Video Information dialog box lets you view basic information about the
video. To open this dialog box, select Tools > Video Information or click

the information button 0 .

= ): MPlay [1] - Video x|
— Video Info
Source type: File
Source name: C:\wiptrain. avi
Frame size: 290 H x 360 W
Color format: RGB

Source data type:  uint8
Display data type:  uintd
Source rate; 30 fps

Frame count: o2&

Ok

Color Map for Intensity Video

The Colormap dialog box lets you change the colormap of an intensity video.
You cannot access the parameters on this dialog box when the GUI displays
an RGB video signal. To open this dialog box for an intensity signal, select
Tools > Colormap or press C.
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= ). Colormap [1] - Video Viewer x|

Calormap: I gray(258) =

™ Specify range of displayed pixel values [0 to 255]

Min: |0 Max: |255

oK. I Cancel | Help Apply

Use the Colormap parameter to specify the colormap to apply to the intensity
video.

Sometimes, the pixel values do not use the entire data type range. In such
cases, you can select the Specify range of displayed pixel values check
box. You can then enter the range for your data. The dialog box automatically
displays the range based on the data type of the pixel values.

Frame Rate
The Frame Rate dialog box displays the frame rate of the source. It also lets

you change the rate at which the MPlay GUI plays the video and displays the
actual playback rate.

Note This dialog box becomes available when you use the MPlay GUI to view
a video signal in a Simulink model.

The playback rate is the number of frames the GUI processes per second. You
can use the Desired playback rate parameter to decrease or increase the
playback rate. To open this dialog box, select Playback > Frame Rate or
press T.
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«): MPlay [1] - Frame Rate x|
—Frame Rate
Source rate; 30 frames sec
Desired playback rate: IW frames sec
Actual playback rate: 0.0 framesfsec
—Frame Drop
[~ allow frame drop to achieve desired playback rate

QK I Cancel Help

Apply

To increase the playback rate when system hardware cannot keep pace

with the desired rate, select the Allow frame drop to achieve desired
playback rate check box. This parameter enables the MPlay GUI to achieve
the playback rate by dropping video frames. Dropped video frames sometimes

cause lower quality playback.

«): MPlay [1] - Frame Rate x|
—Frame Rate
Source rate; 30 frames fsec
Desired playback rate: IW frames sec
Actual playback rate: 0.0 frames/fsec
—Frame Drop

V¥ allow frame drop to achieve desired playback rate

Minimum refresh rate: I 24 frames sec
Maximum refresh rate: I 32 frames sec
Playback schedule: Show 1 frame, Drop O frames

Refresh rate: 30 framessec

QK I Cancel Help

Apply

You can refine further both the quality of playback versus the hardware
burden, by controlling the number of frames to drop per frame or frames
displayed. For example, suppose you set the Desired playback rate to
80 frames/sec. One way to achieve the desired playback rate is to set the
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Playback schedule to Show 1 frame, Drop 3 frames. Change this
playback schedule, by setting both of the refresh rates (which is how often
the GUI updates the screen), to 20 frames/sec. MPlay can achieve the desired
playback rate (in this case, 80 frames/sec) by using these parameter settings.

In general, the relationship between the Frame Drop parameters is:

show _ frames + drop _ frames

Desired _rate = refresh _rate *
show _ frames

In this case, the refresh_rate includes a more accurate calculation based on
both the minimum and maximum refresh rates.

Use the Minimum refresh rate and Maximum refresh rate parameters
to adjust the playback schedule of video display. Use these parameters in
the following way:

¢ Increase the Minimum refresh rate parameter to achieve smoother
playback.

¢ Decrease the Maximum refresh rate parameter to reduce the demand
on system hardware.

Saving the Settings of Multiple MPlay GUIs

The MPlay GUI enables you to save and load the settings of multiple GUI
instances. You only have to configure the MPlay GUIs associated with your
model once.

To save the GUI settings:

® Select File > Instrumentation Sets > Save Set

To open the preconfigured MPlay GUIs:

e Select File > Instrumentation Sets > Load Set

You can save instrument sets for instances of MPlay connected to a source.

If you attempt to save an instrument set for an MPlay instance that is not
connected to a source, the Message Log displays a warning.
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Message Log

The Message Log dialog box provides a system level record of configurations
and extensions used. You can filter what messages to display by Type and
Category, view the records, and display record details.

®* The Type parameter allows you to select either A11, Info, Warn, or Fail
message logs.

¢ The Category parameter allows you to select either Configuration or
Extension message summaries.

® The Configuration message indicates a new configuration file loaded.

e The Extension message indicates a registered component. For example,
a Simulink message, indicating a registered component, available for
configuration.

Status Bar
Along the bottom of the MPlay viewer is the status bar. It displays

information, such as video status, Type of video playing (I or RGB), Frame size,
Percentage of frame rate, Frame rate, and Current frame: Total frames.

Note A minus sign (-) for Current frame indicates reverse video playback.
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Viewing Video File Frames

The MPlay GUI enables you to view videos directly from files without having
to load all the video data into memory at once. The following procedure shows
you how to use the MPlay GUI to load and view a video one frame at a time:

'}

1 On the MPlay GUI, click open file element, L~

2 Use the Connect to File dialog box to navigate to the multimedia file you
want to view in the MPlay window.

For example, navigate to
$matlabroot\toolbox\vipblks\vipdemos\vipmen.avi.

Click Open. The first frame of the video appears in the MPlay window.

) MPlay [1] - File: ¥ipmen.avi 1Ol =]
Fil=  Tools Wiew Playback Help ~

NeBEE B e Ran B 5]

M a m oo

Stopped RGEA20¢160  [100% (30 fps) 11283
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Note The MPlay GUI supports AVI files that The MPlay GUI supports
AVI files that aviread function supports.

3 Experiment with the MPlay GUI by using it to play and interact with the
video stream.
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Analysis and Enhancement

¢ “Feature Extraction” on page 4-2

¢ “‘Image Enhancement” on page 4-30
¢ “Template Matching” on page 4-67
¢ “Pixel Statistics” on page 4-73
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Feature Extraction

In this section...

“Finding Edges in Images” on page 4-2
“Finding Lines in Images” on page 4-9

“Measuring an Angle Between Lines” on page 4-18

Finding Edges in Images
You can use the Edge Detection block to find the edges of objects in an image.
This block finds the pixel locations where the magnitude of the gradient of
intensity is larger than a threshold value. These locations typically occur at
the boundaries of objects. In this section, you use the Edge Detection block to
find the edges of rice grains in an intensity image:

1 Create a Simulink model, and add the blocks shown in the following table.

Block Library Quantity

Image From File Video and Image Processing Blockset | 1
> Sources

Edge Detection Video and Image Processing Blockset | 1
> Analysis & Enhancement

Minimum Video and Image Processing Blockset | 2
> Statistics

Maximum Video and Image Processing Blockset | 2
> Statistics

Video Viewer Video and Image Processing Blockset | 4
> Sinks

Subtract Simulink > Math Operations 2

Divide Simulink > Math Operations 2

2 Place the blocks so that your model resembles the following figure.
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=

File Edit View Simulaton Format Tools Help

DEEHES| BR[| 42 & r =jon | fNoma RS e

Irmages From File

a
il
o
n
il

Image
Wal + I Wal b
I Idx - ek T
ini Subtract - Divids Vides Viewert
Minimum Maximum
val " I val %
I ldx - Idx T
i i N Dividel
Minirurmd Subtracti Maxirmurmd
idec Viewsr2
Ready [100% | | [ode45 Y

You are now ready to set your block parameters by double-clicking the
blocks, modifying the block parameter values, and clicking OK.

3 Use the Image From File block to import your image. Set the parameters
as follows:

¢ File name to rice.png.

® Qutput data type to single.

4 Use the Edge Detection block to find the edges in the image. Set the block
parameters as follows:

e Output type =Binary image and gradient components

® Select the Edge thinning check box.
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5

6

4-4

E! Function Block Parameters: Edge Detection x|

Edge Detection

Finds the edges in an input image using Sobel, Prewitt, Roberts, or Canny methods.

The block outputs a binary image, a matrix of Boolean values, where pixel values equal to 1 correspond to
edges. Alternatively, the block can output two gradient components of the image for the first three
methods,

Main | Fixed-pointl

—Parameters
Method: ISDbE| LI
Qutput type: IBinar*r' image and gradient components LI

™ User-defined threshold

Threshold scale factor:

(used to automatically calculate threshold value) I_}

W Edage thinning

oK. I Cancel Help Apply

The Edge Detection block convolves the input matrix with the Sobel kernel.
This calculates the gradient components of the image that correspond

to the horizontal and vertical edge responses. The block outputs these
components at the Gh and Gv ports, respectively. Then the block performs
a thresholding operation on the gradient components to find the binary
image. The binary image is a matrix filled with 1s and 0s. The nonzero
elements of this matrix correspond to the edge pixels and the zero elements
correspond to the background pixels. The block outputs the binary image
at the Edge port.

View the original image using the Video Viewer block and the binary
image using the Video Viewerl block. Accept the default parameters for
both viewers.

The matrix values at the Gv and Gh output ports from of the Edge
Detection block are double-precision floating-point. These matrix values
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need to be scaled between 0 and 1 in order to display them using the Video
Viewer blocks. This is done with the Statistics and Math Operation blocks.

7 Use the Minimum blocks to find the minimum value of Gv and Gh matrices.

Set the Mode parameters to Value.

8 Use the Subtract blocks to subtract the minimum values from each element

of the Gv and Gh matrices. This process ensures that the minimum value
of these matrices is 0. Accept the default parameters.

9 Use the Maximum blocks to find the maximum value of the new Gv and
Gh matrices. Set the Mode parameters to Value.

10 Use the Divide blocks to divide each element of the Gv and Gh matrices
by their maximum value. This normalization process ensures that these
matrices range between 0 and 1.Accept the default parameters.

11 View the gradient components of the image using the Video Viewerl and
Video Viewer2 blocks. Accept the default parameters.

12 Connect the blocks as shown in the following figure.

E!untitled & _I_l- | ﬂ
File Edit View Simulation Format Tools Help
u : L s
DSE&| B 4|2 r sl o | BaBEd hEE®
e YWideo
Edge P Image Viswar
| Image  all Sobel G ——y
Sh Video Wiswer
Image Frorm Wo kkspace Edge Detection 1
| - Wideo
® 32 iemer
+
> 1 wal - > I Val +
Divide: Viden Viewerl
Subtmct -
fufinirnurn Maeirnurn
:
.
- 1 Val - I val + »
Divide1 )
Subt=ct] - Image .
bdinirnu 1 Mizcsimu Viewer
Wideo Views2
Ready 100% |ode4s v
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13 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time =0
® Solver pane, Type = Fixed-step

® Solver pane, Solver = Discrete (no continuous states)
14 Run your model.

The Video Viewer window displays the original image. The Video Viewerl
window displays the edges of the rice grains in white and the background
in black.

=

File Tools View Playback Help N
B0 [@a 0| &
R LI e

Resady | 2a6x256 T=10.000
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The Video Viewer2 window displays the intensity image of the vertical
gradient components of the image. You can see that the vertical edges of
the rice grains are darker and more well defined than the horizontal edges.

) Video Viewer2

File Tools WView Playback Help

=10l x|

|

B O & &M E

100%

R L o

Resady

12562256

T=0.000

The Video Viewer3 window displays the intensity image of the horizontal
gradient components of the image. In this image, the horizontal edges of

the rice grains are more well defined.
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-l

File Tools WView Playback Help w
B EIEER =
R L o

Ready 1256256 T=0.000

15 Double-click the Edge Detection block and clear the Edge thinning check
box.

16 Run your model again.

Your model runs faster because the Edge Detection block is more efficient
when you clear the Edge thinning check box. However, the edges of rice
grains in the Video Viewer window are wider.
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—ioix

File Tools View Playback Help ~
®|08 (@0 @ -
=@

Resady | 256256 T=0.000

You have now used the Edge Detection block to find the object boundaries in
an image. For more information on this block, see the Edge Detection block
reference page in the Video and Image Processing Blockset Reference.

Finding Lines in Images
Finding lines within images enables you to detect, measure, and recognize

objects. In this section, you use the Hough Transform, Find Local Maxima,
and Hough Lines blocks to find the longest line in an image.

1 Create a Simulink model, and add the blocks shown in the following table.
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Block Library Quantity

Image From File Video and Image Processing Blockset | 1
> Sources

Edge Detection Video and Image Processing Blockset | 1
> Analysis & Enhancement

Hough Transform Video and Image Processing Blockset | 1
> Transforms

Find Local Maxima | Video and Image Processing Blockset | 1
> Statistics

Hough Lines Video and Image Processing Blockset | 1
> Transforms

Draw Shapes Video and Image Processing Blockset | 1
> Text & Graphics

Video Viewer Video and Image Processing Blockset | 2
> Sinks

Variable Selector Signal Processing Blockset > Signal 2
Management > Indexing

Selector Simulink > Signal Routing 2

Terminator Simulink > Sinks 1

2 Place the blocks so that your model resembles the following figure.
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=10/ x|

jon  Format Tools Help

DEEdE|sER|(c= 4|2 » mfios | [iom RS rEE S

persong Imsge Sobe w Housn Vigzo
g Imsg: 1 | Edge B 72" Hough Image '%%%

Imsgs From File Ecgs Detection Hough Transtarm
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Image i er

Ready [100% [odeds 4

You are now ready to set your block parameters by double-clicking the
blocks, modifying the block parameter values, and clicking OK.

3 Use the Image From File block to import your image. Set the File name
parameter to circuit.tif.

4 Use the Edge Detection block to find the edges in the intensity image. This
process improves the efficiency of the Hough Lines block as it reduces the
image area over which the block searches for lines. The block also converts
the image to a binary image, which is the required input for the Hough
Transform block. Accept the default parameters.

5 Use the Video Viewer block to display the original image and the Video
Viewerl block to display the edges found by the Edge Detection block.
Accept the default parameters.

6 Use the Hough Transform block to compute the Hough matrix by
transforming the input image into the rho-theta parameter space. The
block also outputs the rho and theta values associated with the Hough
matrix. Set the block parameters as follows:

¢ Theta resolution (radians) = pi/360

¢ Select the Output theta and rho values check box.
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=] Function Block Parameters: Hough Transform x|

—Hough Transform

Implements the Hough Transform to detect lines.
The block generates a parameter space matrix using the following equation:
rho = x*cos(theta) + y*sin(theta).
The block outputs this matrix at the Hough part. The rows and columns of this matrix correspond to the

rho and theta values, respectively, Peak values in this matrix represent potential straight lines in the
input image.

Mair Fixed-paint I

—Parameters

Theta resolution {radians): Ipi,-"BEuIII

Rhao resolution: I 1

¥ output theta and rho values

Qutput data type: Idnuble ;I

oK I Cancel Help | Apply |

7 Use the Find Local Maxima block to find the location of the maximum
value in the Hough matrix. Set the block parameters as follows:

¢ Maximum number of local maxima (N) = 1

¢ Select the Input is Hough matrix spanning full theta range check
box.
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=] Function Block Parameters: Find Local Maxima x|

—Find Local Maxima (mask) (ink)

Finds local maxima in an input matrix, The size of the search region can be spedified
using the Meighborhood size parameter, Idx output port has the dimension 2-by,
where M is the maximum number of local maxima. This output port holds the row
and column coordinates (0-based) of the local maxima. Threshold value is applied
on the input matrix to find the valid local maxima. The Count port gives the number
of valid local maxima.

If the input is @ Hough matrix generated from a Hough Transform block, the Input
is Hough matrix spanning full theta range check box should be selected. In this
case the block considers that the input Hough matrix is antisymmetric about the rho
axis and theta spans from -pif2 to pif2 radians. If a local maximum is found near a
boundary such that the neighboring windaw lies outside the Hough matrix, the
block picks up only one peak and ignores the corresponding antisymmetric peak.

—Parameters

Maximum nurber of local maxima (M):
1

Meighborhood size:
|[57]

Source of threshold value: ISpeciﬁf via dialog ;I

Threshold:
10

¥ Inputis Hough matrix spanning full theta range

Index output data type: Iuint32 ;I
Count output data type: Iuin132 ;I
Ok Cancel Help | Apply
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8 Use the Selector blocks to separate the indices of the rho and theta values,
which are output at the Idx port, that are associated with the maximum
value in the Hough matrix. Set the Selector block parameters as follows:

® Number of input dimensions: 1

* Index mode = Zero-based
= Index Option = Index vector (dialog)
- Index =0

¢ Input port size =2

Set the Selectorl block parameters as follows:
¢ Number of input dimensions: 1
®* Index mode = Zero-based
= Index Option = Index vector (dialog)
- Index =1
® Input port size =2
9 Use the Variable Selector blocks to index into the rho and theta vectors and
determine the rho and theta values that correspond to the longest line in

the original image. Set the parameters of the Variable Selector blocks as
follows:

e Select = Columns

¢ Index mode = Zero-based

10 Use the Hough Lines block to determine where the longest line intersects
the edges of the original image. You use these coordinates to superimpose
a white line on the original image. Set the Sine value computation
method to Trigonometric function.

11 Use the Draw Shapes block to draw a white line over the longest line on the
original image. Set the block parameters as follows:

e Shape = Lines

¢ Border color = White
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12 Use the Video Viewer2 block to display the original image with a white
line superimposed over the longest line in the image. Accept the default
parameters.

13 Connect the blocks as shown in the following figure.

=] finding_lines_in_images
File Edit View Simulation Format Tools Help

D H&| il e 4y np Nomel MR ES REE®

—lofx|

circuittif  Imags

Imags From Filz

Ready [100%

[FixedStepDiscrete 4

14 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time =0
® Solver pane, Type = Fixed-step
® Solver pane, Solver = Discrete (no continuous states)

15 Run your model.

The Video Viewer window displays the original image.
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o x
File Tools WView Playback Help w
B EIEER =
=@

=
Ready - 280%272 T-0000

Video Viewerl displays the edges found in the original image in white
and the background in black.
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The Video Viewer2 window displays the original image with a white line

drawn over the longest line in the image.
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_lnix

File Tools View Playback Help ~
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Resady | 280272 T=0.000

You have now used the Hough Transform, Find Local Maxima, and Hough
Lines blocks to find the longest line in an image. For more information on
these blocks, see the Hough Transform, Find Local Maxima, and Hough Lines
block reference pages in the Video and Image Processing Blockset Reference.
For additional examples of the techniques used in this section, see the Lane
Departure Warning System and Rotation Correction demos. You can open
these demos by typing vipldws and viphough at the MATLAB command
prompt.

Measuring an Angle Between Lines

The Hough Transform, Find Local Maxima, and Hough Lines blocks enable
you to find lines in images. With the Draw Shapes block, you can annotate
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images. In the following example, you use these capabilities to draw lines on
the edges of two beams and measure the angle between them.

1 Create a new Simulink model, and add to it the blocks shown in the

following table.

Block Library Quantity

Image From File Video and Image Processing Blockset > 1
Sources

Color Space Video and Image Processing Blockset > |1

Conversion Conversions

Edge Detection Video and Image Processing Blockset > |1
Analysis & Enhancement

Hough Transform | Video and Image Processing Blockset > | 1
Transforms

Find Local Video and Image Processing Blockset > 1

Maxima Statistics

Draw Shapes Video and Image Processing Blockset > |1
Text & Graphics

Video Viewer Video and Image Processing Blockset > | 3
Sinks

Hough Lines Video and Image Processing Blockset > 1
Transforms

Submatrix Signal Processing Blockset > Math 4
Functions > Matrices and Linear Algebra
> Matrix Operations

Terminator Simulink > Sinks 1

Selector Simulink > Signal Routing 4

Embedded Simulink > User-Defined Functions 1

MATLAB

Function

Display Simulink > Sinks 1

2 Position the blocks as shown in the following figure.
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4

Use the Image From File block to import an image into the Simulink model.

Set the parameters as follows:

¢ File name = gantrycrane.png

e Sample time = 1

Use the Color Space Conversion block to convert the RGB image into the

Y’CbCr color space. You perform this conversion to separate the luma
information from the color information. Accept the default parameters.

Note In this example, you segment the image using a thresholding
operation that performs best on the Cb channel of the Y’CbCr color space.

Use the Selector and Selectorl blocks to separate the Y’ (luminance) and
Cb (chrominance) components from the main signal.

The Selector block separates the Y’ component from the entire signal. Set
its block parameters as follows:

¢ Number of input dimensions = 3

* Index mode = Zero-based




Feature Extraction

The Selectorl block separates the Cb component from the entire signal.

Index Option = Select all

Index Option = Select all

Index Option = Index vector (dialog)

Index = 1

Set its block parameters as follows:

Use the Submatrix and Submatrix1 blocks to crop the Y’ and Cb matrices
to a particular region of interest (ROI). This ROI contains two beams that

Number of input dimensions = 3
Index mode = Zero-based

1

Index Option = Select all

Index Option = Select all

Index Option = Index vector (dialog)

Index =2

are at an angle to each other. Set the parameters as follows:

Starting row = Index
Starting row index = 66
Ending row = Index
Ending row index = 150
Starting column = Index

Starting column index = 325
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¢ Ending column = Index

¢ Ending column index = 400

7 Use the Edge Detection block to find the edges in the Cb portion of the
image. This block outputs a binary image. Set the Threshold scale
factor parameter to 1.

8 Use the Hough Transform block to calculate the Hough matrix, which gives
you an indication of the presence of lines in an image. Select the Output
theta and rho values check box as shown in the following figure.

Note In step 11, you find the theta and rho values that correspond to the
peaks in the Hough matrix.




Feature Extraction

=] Function Block Parameters: Hough Transform x|

—Hough Transform

Implements the Hough Transform to detect lines.
The block generates a parameter space matrix using the following equation:
rho = x*cos(theta) + y*sin(theta).
The block outputs this matrix at the Hough paort. The rows and columns of this matrix correspond tao the

rho and theta values, respectively, Peak values in this matrix represent potential straight lines in the
input image.

Main Fixed-point I

—Parameters

Theta resolution {radians): Ipi,r'IBEI

Rho resolution: I 1

¥ Cutput theta and rho values

Cutput data type: Iu:h:uul:ule ;I

oK Cancel Help | Apply |

9 Use the Find Local Maxima block to find the peak values in the Hough
matrix. These values represent potential lines in the input image. Set
the parameters as follows:

¢ Neighborhood size = [11 11]

¢ Input is Hough matrix spanning full theta range = selected

Because you are expecting two lines, leave the Maximum number of
local maxima (N) parameter set to 2, and connect the Count port to the
Terminator block.
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10 Use the Submatrix2 block to find the indices that correspond to the theta
values of the two peak values in the Hough matrix. Set the parameters as
follows:

* Starting row = Index

® Starting row index =2

* Ending row = Index

¢ Ending row index =2

The Idx port of the Find Local Maxima block outputs a matrix whose second
row represents the zero-based indices of the theta values that correspond
to the peaks in the Hough matrix. Now that you have these indices, you

can use a Selector block to extract the corresponding theta values from the
vector output of the Hough Transform block.

11 Use the Submatrix3 block to find the indices that correspond to the rho
values of the two peak values in the Hough matrix. Set the parameters as
follows:

¢ Ending row = Index

¢ Ending row index = 1

The Idx port of the Find Local Maxima block outputs a matrix whose first
row represents the zero-based indices of the rho values that correspond to
the peaks in the Hough matrix. Now that you have these indices, you can

use a Selector block to extract the corresponding rho values from the vector
output of the Hough Transform block.

12 Use the Selector2 and Selector3 blocks to find the theta and rho values
that correspond to the peaks in the Hough matrix. These values, output
by the Hough Transform block, are located at the indices output by the
Submatrix2 and Submatrix3 blocks. Set both block parameters as follows:

* Index mode = Zero-based
1
= Index Option = Index vector (port)

® Input port size = -1
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You set the Index mode to Zero-based because the Find Local Maxima
block outputs zero-based indices at the Idx port.

13 Use the Hough Lines block to find the Cartesian coordinates of lines that

are described by rho and theta pairs. Set the Sine value computation
method parameter to Trigonometric function.

14 Use the Draw Shapes block to draw the lines on the luminance portion of
the ROI. Set the parameters as follows:

¢ Shape = Lines
e Border color = White

15 Use the Embedded MATLAB Function block to calculate the angle between
the two lines. Copy and paste the following code into the block:

function angle = compute_angle(theta)

%sCompute the angle value in degrees
angle = abs(theta(1)-theta(2))*180/pi;
%Always return an angle value less than 90 degrees
if (angle>90)
angle = 180-angle;
end

16 Use the Display block to view the angle between the two lines. Accept the
default parameters.

17 Use the Video Viewer blocks to view the original image, the ROI, and the
annotated ROI. Accept the default parameters.

18 Connect the blocks as shown in the following figure.
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19 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

¢ Solver pane, Stop time =0
¢ Solver pane, Type = Fixed-step

® Solver pane, Solver = Discrete (no continuous states)

20 Run the model.
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The Video Viewer window displays the original image.
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The Video Viewerl window displays the ROI where two beams intersect.

Video Viewerl
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The Video Viewer2 window displays the ROI that has been annotated with
two white lines.

o
File Tools View Playback Help -
B0 &aq| o

CR o e

Ready |: 5576 T=10.000

The Display block shows a value of 58, which is the angle in degrees
between the two lines on the annotated ROI.

You have now annotated an image with two lines and measured the angle
between them. For additional information, see the Hough Transform, Find
Local Maxima, Hough Lines, and Draw Shapes block reference pages in the
Video and Image Processing Blockset Reference.
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Image Enhancement

In this section...

“Sharpening and Blurring an Image” on page 4-30
“Removing Salt and Pepper Noise from Images” on page 4-39
“Removing Periodic Noise from Video” on page 4-45

“Adjusting the Contrast in Intensity Images” on page 4-54

“Adjusting the Contrast in Color Images” on page 4-61

Sharpening and Blurring an Image

To sharpen a color image, you need to make the luma intensity transitions
more acute, while preserving the color information of the image. To do this,
you convert an R’G’B’ image into the Y’CbCr color space and apply a highpass
filter to the luma portion of the image only. Then, you transform the image
back to the R'G’B’ color space to view the results. To blur an image, you apply
a lowpass filter to the luma portion of the image. This example shows how

to use the 2-D FIR Filter block to sharpen and blur an image. The prime
notation indicates that the signals are gamma corrected.

1 Define an R°'G’'B’ image in the MATLAB workspace. To read in an R'G'B’
image from a PNG file and cast it to the double-precision data type, at the
MATLAB command prompt, type

I= im2double(imread('peppers.png'));

I is a 384-by-512-by-3 array of double-precision floating-point values.
Each plane of this array represents the red, green, or blue color values
of the image.

2 To view the image this array represents, at the MATLAB command
prompt, type

imshow(I)
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2 Figure 1
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Now that you have defined your image, you can create your model.

3 Create a new Simulink model, and add to it the blocks shown in the

following table.

Block Library Quantity

Image From Video and Image Processing Blockset > | 1

Workspace Sources

Color Space Video and Image Processing Blockset > | 2

Conversion Conversions

2-D FIR Filter Video and Image Processing Blockset > |1
Filtering

Video Viewer Video and Image Processing Blockset > |1

Sinks
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4 Position the blocks as shown in the following figure.
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5 Use the Image From Workspace block to import the R°G’'B’ image from the
MATLAB workspace. Set the parameters as follows:

® Main pane, Value = 1

® Main pane, Image signal = Separate color signals

The block outputs the R’, G, and B’ planes of the I array at the output ports.
6 The first Color Space Conversion block converts color information from

the R'G’B’ color space to the Y'CbCr color space. Set the Image signal
parameter to Separate color signals
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=] Function Block Parameters: Color Space Conversionl x|

—Color Space Conversion (mask) {ink)

Converts color information between color spaces,

Use the Conversion parameter to specify the color spaces you are converting
between. Your choices are R'G'B' to Y'CbCr, ¥'CbCr to R'GE', R'G'E' to intensity,
R'GE' to HSV, H5V to R'G'E', sR'G'E' to X¥Z, XYZ to sR'GE', sR'GE' to L*a*b™, and
L*a*b™ to sR'G'B".

All conversions support double-precision floating-point and single-precision floating-
point inputs, The conversions from R'G'E' to intensity and between the R'G'B' and
¥'CbCr color spaces also suppart 3-bit unsigned integer inputs,

—Parameters

Conversion: IR'G'B' to Y'ChCr

=l
|se conversion specified by: |Rec. 601 (S0TY) ;I
=l

Image signal: ISEparatE color signals

K Cancel Help | Apply

7 Use the 2-D FIR Filter block to filter the luma portion of the image. Set the
block parameters as follows:

e Coefficients = fspecial('unsharp')
® Output size = Same as input port I
¢ Padding options = Symmetric

¢ Filtering based on = Correlation
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E Function Block Parameters: 2-D FIR Filter

— 2-D FIR Filter

Performs two-dimensional FIR filtering of input matrix I using filter coeffident matrix H.

Yfou can use the Filtering based on parameter to spedfy whether your filtering is based on convolution or
correlation,

|Jse the Qutput size parameter to specify the dimensions of the output, Assume that the input at port I has
dimensions (Mi, Mi) and the input at port H has dimensions (Mh, Nh). If you choose Full, the output has
dimensions (Mi+Mh-1, Mi+Mh-1). If you choose Same as input port I, the output has the same dimensions as
the input at port I. If you choose Valid, the block filters the input image only where the coefficient matrix fits
entirely within it, so no padding is required. The output has dimensions (Mi-Mh+1, MNi-Mh+1).

Main | Fixed-pnintl

—Parameters

[ Separable filter coefficients

Coefficient source: ISpecify via dialog LI

Coefficents: Ifspecial(‘unsharp'}

Quiput size: ISame as input port I

Padding options: ISymmetric

Ll Lef Lo

Filtering based on: ICDrreIah’on

QK I Cancel Help Apply

The fspecial('unsharp') command creates two-dimensional highpass
filter coefficients suitable for correlation. This highpass filter sharpens the
image by removing the low frequency noise in it.

The second Color Space Conversion block converts the color information
from the Y'CbCr color space to the R'G’B’ color space. Set the block
parameters as follows:

e Conversion=Y'CbCr to R'G'B"

e Image signal = Separate color signals
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=] Function Block Parameters: Color Space Conversion x|

—Color Space Conversion (mask) {ink)

Converts color information between color spaces,

Use the Conversion parameter to specify the color spaces you are converting
between. Your choices are R'G'B' to Y'CbCr, ¥'CbCr to R'GE', R'G'E' to intensity,
R'GE' to HSV, H5V to R'G'E', sR'G'E' to X¥Z, XYZ to sR'GE', sR'GE' to L*a*b™, and
L*a*b™ to sR'G'B".

All conversions support double-precision floating-point and single-precision floating-
point inputs, The conversions from R'G'E' to intensity and between the R'G'B' and
¥'CbCr color spaces also suppart 3-bit unsigned integer inputs,

—Parameters

Conversion: IY'ChCr to R'GE'

=l
|se conversion specified by: |Rec. 601 (S0TY) ;I
=l

Image signal: ISEparatE color signals

K Cancel Help | Apply

9 Use the Video Viewer block to automatically display the new, sharper
image in the Video Viewer window when you run the model. Set the Image
signal parameter to Separate color signals, by selecting File > Image
Signal.

10 Connect the blocks as shown in the following figure.
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11 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time = 0
® Solver pane, Type = Fixed-step
¢ Solver pane, Solver = Discrete (no continuous states)

12 Run the model.

A sharper version of the original image appears in the Video Viewer
window.
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13 To blur the image, double-click the 2-D FIR Filter block. Set Coefficients
parameter to fspecial('gaussian',[15 15],7) and then click OK.

The fspecial('gaussian',[15 15],7) command creates two-dimensional
Gaussian lowpass filter coefficients. This lowpass filter blurs the image by
removing the high frequency noise in it.
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14 Run the model.

A blurred version of the original image appears in the Video Viewer
window. The following image is shown at its true size.

ol

File Tools View Playback Help ~
B 0% |Qas @l
C R e e

Ready RGE:354x512  T=10.000

In this example, you used the Color Space Conversion and 2-D FIR Filter
blocks to sharpen and blur an image. For more information on these blocks,
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see the Color Space Conversion and 2-D FIR Filter block reference pages in
the Video and Image Processing Blockset Reference. For more information on
the fspecial function, see the Image Processing Toolbox documentation.

Removing Salt and Pepper Noise from Images

Median filtering is a common image enhancement technique for removing
salt and pepper noise. Because this filtering is less sensitive than linear
techniques to extreme changes in pixel values, it can remove salt and pepper
noise without significantly reducing the sharpness of an image. In this topic,
you use the Median Filter block to remove salt and pepper noise from an
intensity image:

1 Define an intensity image in the MATLAB workspace and add noise to it by
typing the following at the MATLAB command prompt:

I= double(imread('circles.png'));
I= imnoise(I, 'salt & pepper',0.02);

I is a 256-by-256 matrix of 8-bit unsigned integer values.

2 To view the image this matrix represents, at the MATLAB command
prompt, type

imshow(I)
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< Figure 1
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The intensity image contains noise that you want your model to eliminate.

3 Create a Simulink model, and add the blocks shown in the following table.

Block Library Quantity
Image From Video and Image Processing Blockset 1
Workspace > Sources
Median Filter Video and Image Processing Blockset 1

> Filtering
Video Viewer Video and Image Processing Blockset 2

> Sinks

4 Position the blocks as shown in the following figure.
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5 Use the Image From Workspace block to import the noisy image into your
model. Set the Value parameter to I.

6 Use the Median Filter block to eliminate the black and white speckles in
the image. Use the default parameters.
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=] Function Block Parameters: Median Filter x|

—Median Filter

Performs Median filtering of input matrix 1.

Lise the Meighborhood size parameter to spedfy the size of the neighborhood over
which the block computes the median.

LUse the Output size parameter to specify the dimensions of the output. If vou select
Same as input port I, the block outputs an intensity image that is the same size as the
image input to the I port. If you select Valid, the block only computes the median
where the neighborhood fits entirely within the input image, so no padding is required.

Main Fixed-paint I

—Parameters

Meighborhood size: I [33]

Qutput size: ISamE as input port I

Padding options: ICDnstant

L L L

Pad value source: ISpEl:iﬁf via dialog

Pad value; I 0

Ok Cancel Help | Apply |

The Median Filter block replaces the central value of the 3-by-3
neighborhood with the median value of the neighborhood. This process
removes the noise in the image.

7 Use the Video Viewer blocks to display the original noisy image, and
the modified image. Images are represented by 8-bit unsigned integers.
Therefore, a value of 0 corresponds to black and a value of 255 corresponds
to white. Accept the default parameters.

8 Connect the blocks as shown in the following figure.
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9 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time = 0
® Solver pane, Type = Fixed-step

¢ Solver pane, Solver = Discrete (no continuous states)
10 Run the model.

The original noisy image appears in the Video Viewer window. To view
the image at its true size, right-click the window and select Set Display
To True Size.
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The cleaner image appears in the Video Viewerl window. The following
image is shown at its true size.
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You have used the Median Filter block to remove noise from your image. For
more information about this block, see the Median Filter block reference page
in the Video and Image Processing Blockset Reference.

Removing Periodic Noise from Video

Periodic noise can be introduced into a video stream during acquisition or
transmission due to electrical or electromechanical interference. In this
example, you remove periodic noise from an intensity video using the 2-D FIR
Filter block. You can use this technique to remove noise from other images or
video streams, but you might need to modify the filter coefficients to account
for the noise frequency content present in your signal:

1 Create a Simulink model, and add the blocks shown in the following table.
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Block Library Quantity
Read Binary File Video and Image Processing Blockset > | 1
Sources
Image Data Type | Video and Image Processing Blockset > | 1
Conversion Conversions
2-D FIR Filter Video and Image Processing Blockset > | 1
Filtering
Video Viewer Video and Image Processing Blockset > | 3
Sinks
Add Simulink > Math Operations 1

2 Open the Periodic noise reduction demo by typing vipstripes at the
MATLAB command prompt.

3 Click-and-drag the Periodic Noise block into your model.

The block outputs a sinusoid with a normalized frequency that ranges
between 0.61m and 0.69mr radians per sample and a phase that varies
between zero and three radians. You are using this sinusoid to represent

periodic noise.

4 Place the blocks so that your model resembles the following figure. The
unconnected ports disappear when you set block parameters.
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You are now ready to set your block parameters by double-clicking the
blocks, modifying the block parameter values, and clicking OK.

Use the Read Binary File block to import a binary file into the model. Set
the block parameters as follows:

* File name = cat_video.bin
* Four character code = GREY

¢ Number of times to play file = inf

Sample time = 1/30
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=] source Block Parameters: Read Binary File x|

—Read Binary File

Read binary video data from file in the specified format.

—Parameters
Filename: Iu:at_\;iu:leu:u.l:uinl Browse. ., |
Video format: IF:::ur character codes ;I
Four character code: IIGF'\Eﬁr ;I
Frame size Rows: |12IZI Cals: IlEuIZI
Line ordering: |T|:||:| line first ;I

Mumber of times to play file: |inf

[T output end-of-file indicator

Sample time: I 1430

QK Cancel Help

6 Use the Image Data Type Conversion block to convert the data type of the
video to single-precision floating point. Accept the default parameter.

7 Use the Video Viewer block to view the original video. Accept the default
parameters.

8 Use the Add block to add the noise video to the original video. Accept the
default parameters.

9 Use the Video Viewerl block to view the noisy video. Accept the default
parameters.

10 Define the filter coefficients in the MATLAB workspace. Type the following
code at the MATLAB command prompt:
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vipdh_stripes

The variable h, as well as several others, are loaded into the MATLAB
workspace. The variable h represents the coefficients of the band reject
filter capable of removing normalized frequencies between 0.61m and 0.69m
radians per sample. The coefficients were created using the Filter Design
and Analysis Tool (FDATool) and the ftrans2 function.

Use the 2-D FIR Filter block to model a band-reject filter capable of
removing the periodic noise from the video. Set the block parameters as
follows:

® Coefficients = h

¢ Output size = Same as input port I

* Padding options = Circular

Choose a type of padding that minimizes the effect of the pixels outside the
image on the processing of the image. In this example, circular padding

produces the best results because it is most effective at replicating the
sinusoidal noise outside the image.
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=] Function Block Parameters: 2-D FIR Filter x|
— 2-D FIR Filter

Performs two-dimensional FIR filtering of input matrix I using filter coefficdent matrix H.

‘fou can use the Filtering based on parameter to specify whether your filtering is based on convolution or
correlation.

Use the Output size parameter to specify the dimensions of the output. Assume that the input at port I has
dimensions (Mi, Ni} and the input at port H has dimensions (Mh, Mh). If you choose Full, the output has
dimensions (Mi+Mh-1, Mi-+Mh-1). If you choose Same as input port I, the output has the same dimensions as
the input at port I. If you choose Valid, the block filters the input image only where the coefficient matrix fits
entirely within it, so no padding is required. The output has dimensions (Mi-Mh+1, MitMh+1).

Main | Fixed-pointl

—Parameters

[~ separable filter coefficients

Coefficent source: ISpecify via dialog LI

Coefficients: I h

Qutput size: ISame as input port I

Padding options: ICircuIar

Filtering based on: IConvoluﬁon

Ll L Led

[o]'4 I Cancel | Help | Apply I

12 Use the Video Viewer2 block to view the approximation of the original
video. Accept the default parameters.

13 Connect the block as shown in the following figure.
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14 Set the configuration parameters. Open the Configuration dialog box by

selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time = inf

¢ Solver pane, Type = Fixed-step

® Solver pane, Solver = Discrete (no continuous states)

15 Run the model.
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The noisy video appears in the Video Viewerl window. The following video
is shown at its true size.
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The approximation of the original video appears in the Video Viewer2
window, and the artifacts of the processing appear near the edges of the
video. The following video is shown at its true size.
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You have used the Read Binary File block to import a binary video into your
model, the 2-D FIR Filter to remove periodic noise from this video, and the
Video Viewer block to display the results. For more information about these
blocks, see the Read Binary File, 2-D FIR Filter, and Video Viewer block
reference pages in the Video and Image Processing Blockset Reference. For
more information about the Filter Design and Analysis Tool (FDATool), see
the Signal Processing Toolbox documentation. For information about the
ftrans2 function, see the Image Processing Toolbox documentation.

Adjusting the Contrast in Intensity Images

This example shows you how to modify the contrast in two intensity images
using the Contrast Adjustment and Histogram Equalization blocks.
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1 Create a new Simulink model, and add to it the blocks shown in the

following table.

Block Library Quantity
Image From File Video and Image Processing Blockset 2
> Sources

Contrast Video and Image Processing Blockset > | 1
Adjustment Analysis & Enhancement

Histogram Video and Image Processing Blockset > | 1
Equalization Analysis & Enhancement

Video Viewer Video and Image Processing Blockset 4

> Sinks

2 Place the blocks so that your model resembles the following figure.
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3 Use the Image From File block to import the first image into the Simulink
model. Set the File name parameter to pout.tif.

4 Use the Image From Filel block to import the second image into the

Simulink model. Set the File name parameter to tire.tif.

5 Use the Contrast Adjustment block to modify the contrast in pout.tif.
Set the Adjust pixel values from parameter to Range determined by
saturating outlier pixels, as shown in the following figure.
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=1 Function Block Parameters: Contrast Adjustment

—Contrast Adjustment

Adjusts the contrast of an image by linearly scaling the pixel values between upper and lower limits,
Pixel values that are above or below this range are saturated to the upper or lower limit values,
respectively,

Main Fixed-point I

—Parameters

Adjust pixel values from: IRangE determined by saturating outlier pixels ;I

Percentage of pixels to saturate [low high] (in %): |[1 1]

¥ Specify number of histogram bins {used to calculate the range when outliers are eliminated)

Mumber of histogram bins: I 256

Adjust pixel values to; IFuII data type range ;I

oK Cancel Help Apply

This block adjusts the contrast of the image by linearly scaling the pixel
values between user-specified upper and lower limits.

6 Use the Histogram Equalization block to modify the contrast in tire.tif.
Accept the default parameters.
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E! Function Block Parameters: Histogram Equalization x|

—Histogram Equalization {mask) {Jink)

Ernhance the contrast of input image using histogram equalization.

—Parameters

Target histogram: |Uniform ;I

Mumber of bins:

04

oK Cancel Help Apply

This block enhances the contrast of images by transforming the values in
an intensity image so that the histogram of the output image approximately
matches a specified histogram.

7 Use the Video Viewer blocks to view the original and modified images.
Accept the default parameters.

8 Connect the blocks as shown in the following figure.
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9 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set

the parameters as follows:

® Solver pane, Stop time = 0

® Solver pane, Type = Fixed-step

¢ Solver pane, Solver = Discrete (no continuous states)

10 Run the model.

The results appear in the Video Viewer windows.
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In this example, you used the Contrast Adjustment block to linearly

scale the pixel values in pout.tif between new upper and lower limits.
You used the Histogram Equalization block to transform the values in

tire.tif so that the histogram of the output image approximately matches

a uniform histogram. For more information, see the Contrast Adjustment

and Histogram Equalization block reference pages in the Video and Image

Processing Blockset Reference.
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Adjusting the Contrast in Color Images

This example shows you how to modify the contrast in color images using
the Histogram Equalization block.

1 Use the following code to read in an indexed RGB image, shadow.tif, and
convert it to an RGB image.

[X map] = imread('shadow.tif');
shadow = ind2rgb(X,map);

2 Create a new Simulink model, and add to it the blocks shown in the

following table.

Block Library Quantity

Image From Video and Image Processing Blockset 1

Workspace > Sources

Color Space Video and Image Processing Blockset 2

Conversion > Conversions

Histogram Video and Image Processing Blockset > | 1

Equalization Analysis & Enhancement

Video Viewer Video and Image Processing Blockset 2
> Sinks

Constant Simulink > Sources 1

Divide Simulink > Math Operations 1

Product Simulink > Math Operations 1

3 Place the blocks so that your model resembles the following figure.
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4 Use the Image From Workspace block to import the RGB image from the

MATLAB workspace into the Simulink model. Set the block parameters as
follows:

e Value = shadow

¢ Image signal = Separate color signals

5 Use the Color Space Conversion block to separate the luma information

from the color information. Set the block parameters as follows:
® Conversion =sR'G'B' to L*a*b*

¢ Image signal = Separate color signals

Because the range of the L* values is between 0 and 100, you must
normalize them to be between zero and one before you pass them to the
Histogram Equalization block, which expects floating point input in this
range.

6 Use the Constant block to define a normalization factor. Set the Constant
value parameter to 100.

7 Use the Divide block to normalize the L* values to be between 0 and 1.
Accept the default parameters.
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8 Use the Histogram Equalization block to modify the contrast in the image.

Accept the default parameters.

E! Function Block Parameters: Histogram Equalizatio

—Hiztogram E qualization [mazk] [link]

Enhance the contrazt of input image wsing histogram equalization.

—Parameterz

Murnber af bins:

Target istogram -

E4

Ok

Cancel

Help

Apply

This block enhances the contrast of images by transforming the luma
values in the color image so that the histogram of the output image
approximately matches a specified histogram.

9 Use the Product block to scale the values back to be between the 0 to 100
range. Accept the default parameters.

10 Use the Color Space Conversionl block to convert the values back to the

sR’G’B’ color space. Set the block parameters as follows:

e Conversion = L*a*b* to sR'G'B'

¢ Image signal = Separate color signals

11 Use the Video Viewer blocks to view the original and modified images. For
each block, set the Image signal parameter to Separate color signals.

12 Connect the blocks as shown in the following figure.
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13 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

¢ Solver pane, Stop time =0
¢ Solver pane, Type = Fixed-step

® Solver pane, Solver = Discrete (no continuous states)

14 Run the model.
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As shown in the following figure, the model displays the original image in
the Video Viewerl window.
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As the next figure shows, the model displays the enhanced contrast image
in the Video Viewer window.
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In this example, you used the Histogram Equalization block to transform
the values in a color image so that the histogram of the output image
approximately matches a uniform histogram. For more information, see
the Histogram Equalization block reference page in the Video and Image
Processing Blockset Reference.
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Template Matching

In this section...

“Using the Template Matching Block” on page 4-67
“Video Stabilization” on page 4-71

“Panorama Creation” on page 4-72

Using the Template Matching Block

Template matching is a technique in image processing for finding subregions
of an image which match a template image. Template matching applications
include manufacturing, robotics, edge, or shape detection and facial
recognition. The matching process moves the template image to all possible
positions in a larger source image. It computes a numerical metric that
indicates how well the template matches the image in that position.

You can use any of the follow metrics for template matching with the Video
and Image Processing Blockset:

® Sum of Absolute Differences (SAD)

® Sum of Squared Differences (SSD)

® Maximum Absolute Difference (MaxAD)

Choosing an Output Option

The block outputs either a matrix of match metric values or the zero-based
location of the best template match. The block outputs the matrix to the
Metric port or the location to the Loe port. Optionally, the block can output
an NxN matrix of neighborhood match metric values to the NMetric port.

Input and Output Signal Sizes
Since the Template Matching block does not pad the input data, it can only
compute values for the match metrics between the input image and the

template for where the template is positioned such that it entirely falls on
the input image. A set of all such positions of the template is termed as the
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valid region of the input image. The size of the valid region is the difference
between the sizes of the input and template images plus one.

Sizeyqlid = SlZ€jnput — Sl2€template 1

The output at the Metric port for the Match metric mode is of the valid
image size. The output at the Loc port for the Best match index mode is a
two-element vector of indices relative to the top-left corner of the input image.

The neighborhood metric output at the NMetric port is of the size NxN where
N must be an odd number defined in the block mask.

Defining the Region of Interest (ROI)

To perform template matching on a subregion of the input image, select the
Enable ROI processing check box. This check box adds an input port ROI
to the Template Matching block. The ROI processing option is only available
for the Best match index mode.

The ROI port requires a four-element vector that defines a rectangular area.
The first two elements represent the zero-based row and column coordinates
for the upper-left corner. The second two elements represent the height and
width of the ROI. The block outputs best match location index relative to
the top left corner of the input image.

Choosing a Match Metric

The block computes the match metric at each step of the iteration. Choose
the match metric which best suits your application. The block evaluates
the best metric value based on the metric choice. The best metric is the
global optimum over the support of the “valid” subregion of the input image
intersected by the ROI, if provided.

Returning the Matrix of Match Metric Values
The matrix of the match metric values always implements single-step

exhaustive window iteration. Therefore, the block computes the metric values
at every pixel.
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Returning the Best Match Location

When in the ROI processing mode, the block treats the image around the ROI
as an extension of the ROI subregion. Therefore, it computes the best match
locations true to the actual boundaries of the ROI. The best match location
indices returned are relative to the top-left corner of the input image.

Returning the Neighborhood Match Metric around the Best Match

If you choose to return the matrix of metric values in a neighborhood around
the best match, an exhaustive loop computes all the metric values for the NxN
neighborhood. This output is particularly useful for performing template
matching with subpixel accuracy.

Choosing a Search Method

When you select Best match location as the output option, you can choose
to use either Exhaustive or Three-step search methods.

The Exhaustive search method is computation intensive because it searches
at every pixel location of the image.

The Three-step search method is a fast search method employing the
following steps:

1 The search starts with a step size equal to or slightly greater than half of
the maximum search range.

2 The block compares nine search points in each step. They comprise the
central point of the search square, and eight search points located on the
search area boundaries.

3 The block decrements the step size by one, after each step, ending the
search with a step size of 1 pixel.

4 At each new step, the block moves the search center to the best matching
point resulting from the previous step.
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Three-Step Search

Using the ROIValid and NValid flags for Diagnostics

The ROIValid and NValid ports represent boolean flags, which track the
valid Region of Interest (ROI) and neighborhood. You can use these flags to
communicate with the downstream blocks and operations.

Valid Region of Interest

If you select the Output flag indicating if ROI is valid check box, the block
adds the ROIValid port. If the ROI lies partially outside the valid image, the
block only processes the intersection of the ROI and the valid image. The
block sets the ROI flag output to this port as follows:

® True, set to 1 indicating the ROI lies completely inside the input image.



Template Matching

® False, set to 0 indicating the ROI lies completely or partially outside of
the input image.

Valid Neighborhood

The neighborhood matrix of metric values is valid inside of the Region of
Interest (ROI). You can use the Boolean flag at the NValid port to track the
valid neighborhood region. The block sets the neighborhood NValid boolean
flag output as follows:

® True, set to 1 indicating that the neighborhood containing the best match is
completely inside the region of interest.

e False, set to 0 indicating that the neighborhood containing the best match
1s completely or partially outside of the region of interest.

Video Stabilization

The Estimate Motion Subsystem for Video Stabilization demo implements the
Template Matching block. The purpose of the model is to track a license plate
of a vehicle while reducing the effect of camera motion from a video stream.

In the first video frame, the model defines the target to track. In this case, it
is the back of a car and the license plate. It also establishes a dynamic search
region, where the last known target location determines the position.

You can find demos for the Video and Image Processing Blockset by typing
vipdemos on the MATLAB command line. You can launch the Video
Stabilization model directly by typing vipstabilize on the MATLAB
command line.
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Panorama Creation

The Motion Estimation Subsystem of the Panorama Creation demo
implements the Template Matching block. This model uses the block to
estimate the motion between consecutive video frames. Then it computes
the motion vector of a particular block in the current frame with respect to
the previous frame. The model uses this motion vector to align consecutive
frames of the video to form a panoramic picture.

You can find demos for the Video and Image Processing Blockset by typing
vipdemos on the MATLAB command line. You can launch the Panorama
model directly by typing vippanorama on the MATLAB command line.
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Pixel Statistics

In this section...

“Blocks That Compute Pixel Statistics” on page 4-73
“Finding the Histogram of an Image” on page 4-73

Blocks That Compute Pixel Statistics

The Video and Image Processing Blockset software together with the Signal
Processing Blockset software contains blocks that can provide information
about the data values that make up an image. Blocks from the Statistics
library, such as the Maximum and 2-D Autocorrelation blocks, can help you
determine this information.

Finding the Histogram of an Image

The Histogram block computes the frequency distribution of the elements in
each input image by sorting the elements into a specified number of discrete
bins. You can use the Histogram block to calculate the histogram of the R,

G, and/or B values in an image. This example shows you how to accomplish

this task:

1 Create a new Simulink model, and add to it the blocks shown in the

following table.

Block Library Quantity
Image From File Video and Image Processing Blockset 1
> Sources
Video Viewer Video and Image Processing Blockset 1
> Sinks
Matrix Simulink > Math Operations 1
Concatenation
Vector Scope Signal Processing Blockset > Signal 1
Processing Sinks
Histogram Signal Processing Blockset > Statistics | 3
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2 Place the blocks so that your model resembles the following figure.
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3 Use the Image From File block to import an RGB image. Set the block

parameters as follows:

® Sample time = inf

¢ Image signal = Separate color signals
® Output port labels: =R|G|B

® Qutput data type: = double
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4 Use the Video Viewer block to automatically display the original image

in the viewer window when you run the model. Set the Image signal
parameter to Separate color signals.

) Video Viewer
File Tools WView Playback Help

=0l x|

|

v Open at Start of Simulation

| 1000 =

One Multi-Dimensional Signal

Image Signal

Configuration Set » Separate Color Signals
Export to Image Toaol Chrl+E

Close Cri+W

Close Al

(Mo data is awvailable until
the simulation starts. )

Ready T=-1.000

5 Use the Histogram block to calculate the histogram of the R, G, and B
values in the image. Set the Main tab block parameters as follows:

¢ Lower limit of histogram: 0
¢ Upper limit of histogram: 1
¢ Number of bins: = 256
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x

Histogram
Histogram of the vector elements. If running histogram is selected, block returns
the histogram of the input elements over time,

Main | Fixed-pointl

—Parameters

Lower limit of histogram: I 0

Upper limit of histogram: I 1

MNumber of bins: I 256

[ Mormalized

™ Punning histogram

oK. I Cancel Help Apply

The R, G, and B input values to the Histogram block are double-precision
floating point and range between 0 and 1. The block creates 256 bins
between the maximum and minimum input values and counts the number
of R, G, and B values in each bin.

6 Use the Matrix Concatenation block to concatenate the R, G, and B column
vectors into a single matrix so they can be displayed using the Vector Scope
block. Set the Number of inputs parameter to 3.

7 Use the Vector Scope block to display the histograms of the R, G, and B
values of the input image. Set the block parameters as follows:

®* Scope Properties pane, Input domain = User-defined

¢ Display Properties pane, clear the Frame number check box

¢ Display Properties pane, select the Channel legend check box
¢ Display Properties pane, select the Compact display check box
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i

Axis Properties pane, clear the Inherit sample increment from
input check box.

Axis Properties pane, Minimum Y-limit =0
Axis Properties pane, Maximum Y-limit = 1
Axis Properties pane, Y-axis title = Count
Line Properties pane, Line markers = . |s|d

Line Properties pane, Line colors =[1 0 0]|[0 1 0]|[0 O 1]

8 Connect the blocks as shown in the following figure.
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9 Set the configuration parameters. Open the Configuration dialog box by

selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time =0
® Solver pane, Type = Fixed-step
® Solver pane, Solver = Discrete (no continuous states)

10 Run the model.

The original image appears in the Video Viewer window.

) Video Viewer
File Tools Wiew Playback Help

B O K& &
C I L =

=10l x|

| 100% Rd

Ready

RGE:364x512  T=10.000

11 Right-click in the Vector Scope window and select Autoscale.
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The scaled histogram of the image appears in the Vector Scope window.
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+10000 —4—CH3

000

You have now used the Histogram block to calculate the histogram of the R,
G, and B values in an RGB image. For more information about this block,
see the Histogram block reference page in the Video and Image Processing
Blockset Reference. To open a demo model that illustrates how to use this
block to calculate the histogram of the R, G, and B values in an RGB video
stream, type viphistogram at the MATLAB command prompt.
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® “Intensity to Binary Conversion” on page 5-2
e “Color Space Conversion” on page 5-15

¢ “Chroma Resampling” on page 5-21
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Intensity to Binary Conversion

In this section...

“Overview of Intensity and Binary Images” on page 5-2

“Thresholding Intensity Images Using Relational Operators” on page 5-2

“Thresholding Intensity Images Using the Autothreshold Block” on page 5-8

Overview of Intensity and Binary Images

Binary images contain Boolean pixel values that are either 0 or 1. Pixels
with the value 0 are displayed as black; pixels with the value 1 are displayed
as white. Intensity images contain pixel values that range between the
minimum and maximum values supported by their data type. Intensity
images can contain only Os and 1s, but they are not binary images unless
their data type is Boolean.

Thresholding Intensity Images Using Relational
Operators

You can use the Relational Operator block to perform a thresholding operation
that converts your intensity image to a binary image. This example shows
you how to accomplish this task:

1 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity

Image From File Video and Image Processing 1
Blockset > Sources

Video Viewer Video and Image Processing 2
Blockset > Sinks

Relational Operator Simulink > Logic and Bit 1
Operations

Constant Simulink > Sources 1
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2 Position the blocks as shown in the following figure.
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3 Use the Image from File block to import your image. In this example the
image file is a 256-by-256 matrix of 8-bit unsigned integer values that
range from 0 to 255. Set the File name parameter to rice.png

4 Use the Video Viewerl block to view the original intensity image. Accept
the default parameters.

5 Use the Constant block to define a threshold value for the Relational
Operator block. Since the pixel values range from 0 to 255, set the
Constant value parameter to 128. This value is image dependent.

6 Use the Relational Operator block to perform a thresholding operation
that converts your intensity image to a binary image. Set the Relational
Operator parameter to >. If the input to the Relational Operator block
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1s greater than 128, its output is a Boolean 1; otherwise, its output is
a Boolean 0.

E! Function Block Parameters: Relational Operator x|

Relational Operator

Applies the selected relational operator to the inputs and outputs the result, The top (or left) input
corresponds to the first operand.

Main | signal Attributes |

Relational operator: I = j

¥ | Engble zero-crossing detection

Sample time (-1 for inherited):

-1

h)' K Cancel Help Apply

7 Use the Video Viewer block to view the binary image. Accept the default
parameters.

8 Connect the blocks as shown in the following figure.
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9 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

¢ Solver pane, Stop time = 0
® Solver pane, Type = Fixed-step
® Solver pane, Solver = Discrete (no continuous states)

10 Run your model.

The original intensity image appears in the Video Viewerl window.
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The binary image appears in the Video Viewer window.
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Note A single threshold value was unable to effectively threshold this
image due to its uneven lighting. For information on how to address this
problem, see “Correcting for Nonuniform Illumination” on page 7-10.

You have used the Relational Operator block to convert an intensity image
to a binary image. For more information about this block, see the Relational
Operator block reference page in the Simulink documentation. For another
example that uses this technique, see “Counting Objects in an Image” on page

7-3. For additional information, see “Converting Between Image Types” in the
Image Processing Toolbox documentation.
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Thresholding Intensity Images Using the
Avutothreshold Block

In the previous topic, you used the Relational Operator block to convert an
intensity image into a binary image. In this topic, you use the Autothreshold

block to accomplish the same task. Use the Autothreshold block when lighting
conditions vary and the threshold needs to change for each video frame.

1 If the model you created in “Thresholding Intensity Images Using
Relational Operators” on page 5-2 is not open on your desktop, you can

open an equivalent model by typing

doc_thresholding

at the MATLAB command prompt.
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2 Use the Image from File block to import your image. In this example the
image file is a 256-by-256 matrix of 8-bit unsigned integer values that
range from 0 to 255. Set the File name parameter to rice.png

3 Delete the Constant and the Relational Operator blocks in this model.

4 From the Video and Image Processing Blockset library, and then from the
Conversions library, click-and-drag an Autothreshold block into your model.

5 Connect the blocks as shown in the following figure.

=] doc_thresholding * i m

File Edit View Simulation Format Tools Help

Dl£ﬂ§|%ﬂ|¢==ﬁ>‘&‘|gq » II1E.3 INDrrnaI j|

Video
io=.png Imags || Autothreshcld BW—Jmlmage |~
Viewsr
Image From File Autothrashold Vides Viewsr
Video
—image | "=
ViEwne
Video Viewer1
| | |ode4s

Ready |100%

6 Use the Autothreshold block to perform a thresholding operation that
converts your intensity image to a binary image. Select the Output

threshold check box.
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E! Function Block Parameters: Autothreshold x|

—Autathreshold
Automatically converts an intenzity imaage to a binary image.  Thiz block uses Otzu's method,
which determines the threzhald by zplitting the histogram of the input image such that the

variance for each of the pixel groups iz minimized.

Optionally, the block can autput & metric that indicates effectivengss of threshalding of the
input image.  The lower bound of the metric [zera) iz attainable only by images having a single

gray level, and the upper bound [one] iz attainable only by bwo-valued images.

bd air IFi:-ted-pnint I

—Parameters
Threzhalding nperatnr:l » :I
¥ Dutput threshald

[~ Dutput effectiveness metric

[~ Specify data range

[~ Scale threzhold

Apply |

ak | Cahicel

The block outputs the calculated threshold value at the Th port.

7 From the Signal Processing Blockset library, and then from the Signal
Processing Sinks library, click-and-drag a Display block into the model.

Connect it to the Th port.

Your model should look similar to the following figure:
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=] doc_autothreshold

File Edit View Simulation Format Tools Help

=10 >

DEEHE| & 2R | 19 & PIIE | Nomal

H

EW —» Image .

rice.png Imags B | Autothreshold

Th —

Imegs From Fils Autothreshold

Display

Ready [100% | | [FixedstepDiscrete

8 Double-click the Image From Workspace block. On the Data Types pane,
set the Output data type parameter to double.

9 If you have not already done so, set the configuration parameters. Open the
Configuration dialog box by selecting Configuration Parameters from
the Simulation menu. Set the parameters as follows:

® Solver pane, Stop time =0

® Solver pane, Type = Fixed-step

® Solver pane, Solver = Discrete (no continuous states)
10 Run the model.

The original intensity image appears in the Video Viewerl window.
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T=Y
=}

File Tools View Playback Help

B O &[] ~]

Ready | 256256 T=0.000

The binary image appears in the Video Viewer window.
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) videoviewer

Fil=: Tools View Playback Help

BEIEEIEEY

e
)

100% - |

=~ | @R

Ready [ 256256 T=0.000

In the model window, the Display block shows the threshold value,
calculated by the Autothreshold block, that separated the rice grains from

the background.
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=] doc_autothreshold

File Edit View Simulation Format Tools Help

DEEHE| & 2R | 19 & PIIE | Nomal

EW |—{ Image ".:ilji-:
rice.png Imags | Autothreshold EE
Th b—
Video Views
Imegs From Fils Autothreshold
Video
| Image figwe - 131
Display
Video Viewer1
Ready [100% | | [FixedstepDiscrete

You have used the Autothreshold block to convert an intensity image to a
binary image. For more information about this block, see the Autothreshold
block reference page in the Video and Image Processing Blockset Reference. To
open a demo model that uses this block, type vipstaples at the MATLAB

command prompt.
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Color Space Conversion

In this section...

“Overview of Color Space Conversion Block” on page 5-15

“Converting Color Information from R’G’B’ to Intensity” on page 5-15

Overview of Color Space Conversion Block

The Color Space Conversion block enables you to convert color information
from the R’G’B’ color space to the Y'CbCr color space and from the Y'CbCr
color space to the R’G’B’ color space as specified by Recommendation ITU-R
BT.601-5. This block can also be used to convert from the R’G’B’ color space to
intensity. The prime notation indicates that the signals are gamma corrected.

Converting Color Information from R’G’B’ to Intensity

Some image processing algorithms are customized for intensity images. If
you want to use one of these algorithms, you must first convert your image
to intensity. In this topic, you learn how to use the Color Space Conversion
block to accomplish this task. You can use this procedure to convert any
R’G’'B’ image to an intensity image:

1 Define an R’G’'B’ image in the MATLAB workspace. To read in an RG’B’
image from a JPG file, at the MATLAB command prompt, type

I= imread('greens.jpg');

I is a 300-by-500-by-3 array of 8-bit unsigned integer values. Each plane of
this array represents the red, green, or blue color values of the image.

2 To view the image this matrix represents, at the MATLAB command
prompt, type

imshow(I)
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2 Figure 1

File Edit View Insert Tools Desktop ‘Window Help

D& K RaN® ¢ 0EH 0O

3 Create a new Simulink model, and add to it the blocks shown in the

following table.

Block Library Quantity
Image From Video and Image Processing 1
Workspace Blockset > Sources

Color Space Video and Image Processing 1
Conversion Blockset > Conversions

Video Viewer Video and Image Processing 1

Blockset > Sinks

4 Position the blocks as shown in the following figure.




Color Space Conversion

it

File Edit Wiew Simulation Format Tools  Help

O @EHE&| & BB 42z II'ID.D INormaI = 58 e

checker_boad(10) Image i%gchro Image \,\;risf;r
Image From Workspace Golor Space Video Viewer
Comersion
Ready [100% | [ [odeas v

Once you have assembled the blocks needed to convert a R'G’B’ image to an
intensity image, you are ready to set your block parameters. To do this,
double-click the blocks, modify the block parameter values, and click OK.

5 Use the Image from Workspace block to import your image from the
MATLAB workspace. Set theValue parameter to I.

6 Use the Color Space Conversion block to convert the input values from the

R’G’B’ color space to intensity. Set the Conversion parameter to R'G'B'
to intensity.
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) Function Block Parameters: Color Space Conversion |

— Color Space Conversion [mask] (link]

Coreverts color information between color zpaces.

|Jze the Corversion parameter to specify the color spaces you are converting
between, our choices are R'G'B' to v"ChCr, ¥'ChCr to B'G'E', R'G'B' ta intengity,
R'G'B' to HSY, HSY to R'G'E", sR'G'B" toxvZ, »vZ to sR'G'E', sR'G'B' to L*a"b", and
L*a*b* to sR'G'B".

All converziong support double-precizsion floating-point and single-precizion

floating-point inputs, The conversions from R'G'B' to intengity and betveen the R'G'E'
and "ChCr color zpaces alzo support 3-bit unzigned integer inputs,

—Parameters
Cnnversion:l R'G'E" to inkenszity LI
Image signal:l One multidimensional signal LI

7 View the modified image using the Video Viewer block. Accept the default
parameters.

8 Connect the blocks so that your model is similar to the following figure.

~iBix

File Edit Wiew Simulation Format Tools Help

O @EHE&| & BB 42z II'ID.D INormaI || B gk

N - RGE o R
5 = inte nsity = 92 Viewer
Image From Workspace Golor Space Video Viewer
Conversion
Ready [100% | [ [odeas v

9 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:
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® Solver pane, Stop time =0
® Solver pane, Type = Fixed-step
® Solver pane, Solver = Discrete (no continuous states)

10 Run your model.

The image displayed in the Video Viewer window is the intensity version
of the greens. jpg image.

) video Viewer - 10| x|
File Tools WView Playback Help w
EEIEENIE

C IR e

Ready [ 300500 T=0.000

In this topic, you used the Color Space Conversion block to convert color
information from the R’G’B’ color space to intensity. For more information on
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this block, see the Color Space Conversion block reference page in the Video
and Image Processing Blockset Reference.

5-20



Chroma Resampling

Chroma Resampling

The Y’CbCr color space separates the luma (Y’) component of an image from
the chroma (Cb and Cr) components. Luma and chroma, which are calculated
using gamma corrected R, G, and B (R’, G’, B’) signals, are different quantities
than the CIE chrominance and luminance. Because the human eye is more
sensitive to changes in luma than to changes in chroma, you can reduce the
bandwidth required for transmission or storage of a signal by removing some
of the color information. For this reason, this color space is often used for
digital encoding and transmission applications. In the following example, you
use the Chroma Resampling block to downsample the Cb and Cr components
of an image:

1 Define an RGB image in the MATLAB workspace. To read in an RGB
image from a TIF file, at the MATLAB command prompt, type

I= imread('autumn.tif');

I is a 206-by-345-by-3 array of 8-bit unsigned integer values. Each plane of
this array represents the red, green, or blue color values of the image.

2 To view the image this array represents, at the MATLAB command
prompt, type

imshow(I)

5-21



5 Conversions

5-22

) Figure 1
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3 Create a new Simulink model, and add to it the blocks shown in the

following table.

Block Library Quantity

Image From Video and Image Processing 1

Workspace Blockset > Sources

Image Pad Video and Image Processing 1
Blockset > Utilities

Color Space Video and Image Processing 2

Conversion Blockset > Conversions

Chroma Resampling Video and Image Processing 2
Blockset > Conversions

Video Viewer Video and Image Processing 1
Blockset > Sinks

Selector Simulink > Signal Routing 3

4 Position the blocks as shown in the following figure.



Chroma Resampling

] untitled * -1a] x|
File Edit View Simulation Format Tools Help
=] y Lo o
DISE& | s=B|c |2z |) [ [om  SDeBSs REES
o
—
Selector
chedier_board(10) Image Image Fad o = REE to RE'E to Image \f.ideo
— ChCr ChCr Wiewer
Selectar
Image From Warksp ace Image Pad ColorSpface ch cb cb b Color Space Video Wiewer
Conversion aqatn 4aatn Conversion1
o B 422 42:2
— Cr crp o Acr Cr
Selectorz Chroma Chrama
Rezampling Rezampling1
Ready [100% [ [ |ode4s 4

The blocks to the left of and including the Chroma Resampling block
represent the transmission portion of the model. The remaining blocks
represent the receiving portion of the model. Once you have assembled
these blocks, you are ready to set your block parameters. To do this,
double-click the blocks, modify the block parameter values, and click OK.

5 Use the Image from Workspace block to import your image from the
MATLAB workspace. Set the Value parameter to I.

6 Use the Image Pad block to change the dimensions of the I array from
206-by-345-by-3 to 206-by-346-by-3. You are changing these dimensions
because the Chroma Resampling block requires that the dimensions of the
input be divisible by 2. Set the block parameters as follows:

¢ Method = Symmetric
¢ Pad rows at = Right
¢ Pad size along rows = 1

¢ Pad columns at = No padding
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E Function Block Parameters: Image Pad x|

—Image Pad [mazk] (link)

Perfarm two-dimensional padding of an input image.

Pad your image by adding rows to the top and/or botbom of wour image and columne
to the left and/or right zide of pour image. To specify a different padding size at the
top and bottom or left and right gside of pour image, use a two-element vector, The first
element denotes the padding at the top or left side of vour image. The second
element denotes the padding at the bottom or right side of wour image.

‘fou can pad your matix with & constant value, specified by the Value parameter or
the Fyal input port. 1n addition, you can pad your matrix by repeating its border
values, uzing itz mirrar image, of using a circular repetition of its elements.

—Parameters

tethod: I Syummetric

Specif_l,l:l Pad zize

Lol Lef L]

Pad roves at:l Right
Pad zize along roms:
1

Pad colunins at:l Mo padding LI

ak I Cancel

The Image Pad block adds one column to the right of each plane of the
array by repeating its border values. This padding minimizes the effect
of the pixels outside the image on the processing of the image.

Note When processing video streams, it is computationally expensive to
pad every video frame. You should change the dimensions of the video
stream before you process it with Video and Image Processing Blockset

blocks.




Chroma Resampling

7 Use the Selector blocks to separate the individual color planes from the
main signal. This simplifies the color space conversion section of the model.
Set the Selector block parameters as follows:

¢ Number of input dimensions = 3
e 1
= Index Option = Select all
e 2
= Index Option = Select all
e 3
= Index Option = Index vector (dialog)

- Index =1

Set the Selectorl block parameters as follows:
¢ Number of input dimensions = 3
e 1
= Index Option = Select all
e 2
= Index Option = Select all
e 3
= Index Option = Index vector (dialog)

= Index=2

Set the Selector2 block parameters as follows:
¢ Number of input dimensions = 3
e 1
- Index Option = Select all
e 2
- Index Option = Select all
e 3
- Index Option = Index vector (dialog)

- Index=3
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8 Use the Color Space Conversion block to convert the input values from the
R’G’B’ color space to the Y'CbCr color space. The prime symbol indicates

a gamma corrected signal. Set the Image signal parameter to Separate
color signals.

9 Use the Chroma Resampling block to downsample the chroma components

of the image from the 4:4:4 format to the 4:2:2 format. Use the default
parameters.

E Function Block Parameters: Chroma Resampling x|

—Chroma Resampling [mask] [link]

Downzample or upzample chioma components of avCbCr signal to reduce
the bandwidth and/or storage requirements.

—Parameters
Hesampling:l 4440422 LI
Antialiazing filter:l Drefault ;I
Cancel Help | Apply |

The dimensions of the output of the Chroma Resampling block are smaller

than the dimensions of the input. Therefore, the output signal requires less
bandwidth for transmission.

10 Use the Chroma Resampling1 block to upsample the chroma components of

the image from the 4:2:2 format to the 4:4:4 format. Set the Resampling
parameter to 4:2:2 to 4:4:4.

11 Use the Color Space Conversionl block to convert the input values from the

Y’CbCr color space to the R'G'B’ color space. Set the block parameters as
follows:

e Conversion =Y'CbCr to R'G'B"

¢ Image signal = Separate color signals

12 Use the Video Viewer block to display the recovered image. Set the Image
signal parameter to Separate color signals.

13 Connect the blocks as shown in the following figure.



Chroma Resampling

] untitled * —al x|
File Edit View Simulation Format Tools Help
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14 Configure Simulink to display signal dimensions next to each signal line.
Click Format > Port/Signal Displays > Signal Dimensions.

15 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

¢ Solver pane, Stop time =0
¢ Solver pane, Type = Fixed-step

® Solver pane, Solver = Discrete (no continuous states)

16 Run the model.

The recovered image appears in the Video Viewer window.
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) Video Viewer =10l x|
File Tools WView Playback Help
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100% -]

Ready

RGE 206x346  T=0.000

17 Examine the signal dimensions in your model. The Chroma Resampling
block downsamples the Cb and Cr components of the image from 206-by-346
matrices to 206-by-173 matrices. These matrices require less bandwidth

for transmission while still communicating the information necessary to
recover the image after it is transmitted.

You have used the Chroma Resampling block to downsample the Cb and
Cr components of an image. For more information about this block, see the

Chroma Resampling block reference page in the Video and Image Processing
Blockset Reference.



Geometric Transformation

® “Geometric Transformation Interpolation Methods” on page 6-2
¢ “Rotating an Image” on page 6-6
¢ “Resizing an Image” on page 6-14

® “Cropping an Image” on page 6-20
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Geometric Transformation Interpolation Methods

In this section...

“Overview of Interpolation Methods” on page 6-2
“Nearest Neighbor Interpolation” on page 6-2
“Bilinear Interpolation” on page 6-3

“Bicubic Interpolation” on page 6-4

Overview of Interpolation Methods

The Geometric Transformations library of Video and Image Processing
Blockset software contains blocks that perform geometric transformations.
These blocks use interpolation to calculate the appropriate pixel values so
that images appear rotated, translated, resized, or sheared.

Note The examples in the following sections are illustrations of interpolation
methods. The block algorithms are implemented in a slightly different way
so that they are optimized for speed and memory.

Nearest Neighbor Interpolation

For nearest neighbor interpolation, the block uses the value of nearby
translated pixel values for the output pixel values.

For example, suppose this matrix,

1
4
7

@ Ot N
© O W

represents your input image. You want to translate this image 1.7 pixels in
the positive horizontal direction using nearest neighbor interpolation. The

Translate block’s nearest neighbor interpolation algorithm is illustrated by
the following steps:



Geometric Transformation Interpolation Methods

1 Zero pad the input matrix and translate it by 1.7 pixels to the right.

Translated zero-padded matrix

0 0 2 1 3 2 0 0
0 0 5 4 6 5 0
0 0 8 79 8 0 0

A
\ 4

1
4
7

Original zero-padded matrix

1.7 pixels

2 Create the output matrix by replacing each input pixel value with the
translated value nearest to it. The result is the following matrix:

001 2 3
0 0 456
007 89

Note You wanted to translate the image by 1.7 pixels, but this method
translated the image by 2 pixels. Nearest neighbor interpolation is
computationally efficient but not as accurate as bilinear or bicubic
interpolation.

Bilinear Interpolation

For bilinear interpolation, the block uses the weighted average of two
translated pixel values for each output pixel value.

For example, suppose this matrix,

1
4
7

@ Ot N
© O W
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represents your input image. You want to translate this image 0.5 pixel in
the positive horizontal direction using bilinear interpolation. The Translate
block’s bilinear interpolation algorithm is illustrated by the following steps:

1 Zero pad the input matrix and translate it by 0.5 pixel to the right.

Translated zero-padded matrix

0 1 1 2 2 3 3 0 0
0 4 4 5 5 6 6 0 0
0 7 7 8 8 9 9 0 0

—>

|

Original zero-padded matrix 0.5 pixel

2 Create the output matrix by replacing each input pixel value with the
weighted average of the translated values on either side. The result is
the following matrix where the output matrix has one more column than

the input matrix:

05 15 25 1.5
2 45 55 3
3.5 75 85 45

Bicubic Interpolation
For bicubic interpolation, the block uses the weighted average of four
translated pixel values for each output pixel value.

For example, suppose this matrix,

o Ot N
© O W

1
4
7
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represents your input image. You want to translate this image 0.5 pixel in
the positive horizontal direction using bicubic interpolation. The Translate
block’s bicubic interpolation algorithm is illustrated by the following steps:

1 Zero pad the input matrix and translate it by 0.5 pixel to the right.

Translated zero-padded matrix

|

0 0 0 1 1 2 2 3 3 0 0 0 0
0 0 0 4 4 5 5 6 6 0 0 0 0
0 0 0 7 7 8 8 9 9 0 0 0 0

Original zero-padded matrix

0.5 pixel

2 Create the output matrix by replacing each input pixel value with the
weighted average of the two translated values on either side. The result is
the following matrix where the output matrix has one more column than
the input matrix:

0375 1.5 3 1.625
1.875 4.875 6.375 3.125
3.375 8.25 9.75 4.625
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Rotating an Image

You can use the Rotate block to rotate your image or video stream by a
specified angle. In this example, you learn how to use the Rotate block to

continuously rotate an image:

1 Define an RGB image in the MATLAB workspace. At the MATLAB

command prompt, type

I = checker_board;

I is a 100-by-100-by-3 array of double-precision values. Each plane of the
array represents the reg, green, or blue color values of the image.

2 To view the image this matrix represents, at the MATLAB command

prompt, type

imshow(I)

) Figure SI=TEY

FEVITTiDe Wik w

D& >

3 Create a new Simulink model, and add to it the blocks shown in the

following table.

Block Library Quantity
Image From Video and Image Processing 1
Workspace Blockset > Sources




Rotating an Image

Block Library Quantity

Rotate Video and Image Processing 1
Blockset > Geometric
Transformations

Video Viewer Video and Image Processing 2
Blockset > Sinks

Gain Simulink > Math Operations 1

Display Signal Processing Blockset > 1
Signal Processing Sinks

Counter Signal Processing Blockset > 1

Signal Management > Switches
and Counters

4 Position the blocks as shown in the following figure.
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You are now ready to set your block parameters by double-clicking the
blocks, modifying the block parameter values, and clicking OK.

5 Use the Image From Workspace block to import the RGB image from
the MATLAB workspace. On the Main pane, set the Value parameter to
I.Each plane of the array represents the reg, green, or blue color values
of the image.

6 Use the Video Viewer block to display the original image. Accept the
default parameters.

The Video Viewer block automatically displays the original image in
the Video Viewer window when you run the model. Because the image
is represented by double-precision floating-point values, a value of 0
corresponds to black and a value of 1 corresponds to white.




Rotating an Image

7 Use the Rotate block to rotate the image. Set the block parameters as
follows:

e Rotation angle source = Input port

® Sine value computation method = Trigonometric function

E! Function Block Parameters: Rotate x|

—Flotate

Ratates an image by an angle in radians. v'ou can specify this angle uzing the block parameters dialog box
of input port Angle.

Uze the Output size parameter to determing the size of the autput. IF pou select Expanded to fit rotated input
imaage, the block outputs a matrix that containg all the rotated image values and zeros elzewhere. If you
zelect Same as input image, the block outputs a matrix that contains the middle part of the ratated image
and zeros elsewhere. As a rezult, the edges of the ratated image might be cropped.

When gpecifying the rotation angle using the Angle port, the maximum angle value should be greater than 0
bt legs than or egual to pi radianz.

Main IFi:-ted-pc-int |

—Parameters

Output size: I Expanded to fit ratated input image

Lel Lo

Ratation angle source:l Input port

b axirnurn angle [enter pi radians to accommaodate all pozitive and negative angles): Ipi

Dizplay rotated image in:l Center

Lol Lo

Sine walue computation methnd:l Trigonometric function

B ackground fill value: ID

Interpolation methnd:l Bilinear

L]

Ok, I Cancel

Appli

The Angle port appears on the block. You use this port to input a steadily
increasing angle. Setting the Output size parameter to Expanded to fit
rotated input image ensures that the block does not crop the output.
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8 Use the Video Viewerl block to display the rotating image. Accept the
default parameters.

9 Use the Counter block to create a steadily increasing angle. Set the block
parameters as follows:

¢ Count event = Free running

¢ Counter size = 16 bits

¢ Output = Count

® (Clear the Reset input check box.
e Sample time = 1/30

The Counter block counts upward until it reaches the maximum value
that can be represented by 16 bits. Then, it starts again at zero. You can
view its output value on the Display block while the simulation is running.
You are using the Counter block from Signal Processing Blockset software
because its Count data type parameter enables you to specify the data
type of its output.

10 Use the Gain block to convert the output of the Counter block from degrees
to radians. Set the Gain parameter to pi/180.

11 Connect the blocks as shown in the following figure.
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12 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

¢ Solver pane, Stop time = inf
® Solver pane, Type = Fixed-step
¢ Solver pane, Solver = Discrete (no continuous states)

13 Run the model.

The original image appears in the Video Viewer window.
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-ioix]
=}

File Tools View Playback Help
B EIEENIEES
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Reacy RGE:100x100  T=10.000

The rotating image appears in the Video Viewerl window.
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=
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In this example, you used the Rotate block to continuously rotate your image.
For more information about this block, see the Rotate block reference page
in the Video and Image Processing Blockset Reference. For more information
about other geometric transformation blocks, see the Resize and Shear block
reference pages.

Note If you are on a Windows operating system, you can replace the Video
Viewer block with the To Video Display block, which supports code generation.
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Resizing an Image

You can use the Resize block to change the size of your image or video stream.
In this example, you learn how to use the Resize block to reduce the size

of an image:

1 Create a new Simulink model, and add to it the blocks shown in the

following table.

Block Library Quantity

Image From File Video and Image Processing 1
Blockset > Sources

Resize Video and Image Processing 1
Blockset > Geometric
Transformations

Video Viewer Video and Image Processing 2

Blockset > Sinks

2 Position the blocks as shown in the following figure.
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3 Use the Image From File block to import the intensity image. Set the File
name parameter to moon.tif. The tif file is a 537-by-358 matrix of 8-bit
unsigned integer values.

4 Use the Video Viewer block to display the original image. Accept the
default parameters.

The Video Viewer block automatically displays the original image in the
Video Viewer window when you run the model.

5 Use the Resize block to shrink the image. Set the Resize factor in %
parameter to 50.
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E Function Block Parameters: Resize x|

— Resize

Change the size of an image or a region of interest within an image.

|Uze the Specify parameter to designate the parameters you want to use to resize your
imaage. Y'ou can specify a zcalar percentage that iz applied to bath rows and calumns,
ar Yol can specify a bwo-element vector to scale the rows and columnz differently.
'ou can specify the number of roves and/or columis pou want your output image to
have, and you can prezerve of change the image's aspect ratio.

|Uze the Interpolation method parameter b specify the tupe of interpolation performed
by the block when it iz resizing a image. If you zelect the Perfarm antialiazing when
rezize factor is between 0 and 1 check box, the block perfarms lowpas: filkering on
the input image befare shrinking it.

M ain | Firned-point

— Parameter.

Specify; IEIutput zize gz a percentage of input size ;I

Resize factor in 22 IED

Interpolation method: IEiIinear LI

¥ Perform antialiazing when resize factor is between 0 and 100

ok I Cancel Help | Apply |

The Resize block shrinks the image to half its original size.

6 Use the Video Viewerl block to display the modified image. Accept the
default parameters.

7 Connect the blocks as shown in the following figure.
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8 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time =0
® Solver pane, Type = Fixed-step
® Solver pane, Solver = Discrete (no continuous states)

9 Run the model.

The original image appears in the Video Viewer window.
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Resizing an Image

The reduced image appears in the Video Viewerl window. Right-click the
window and select Set Display To True Size. The smaller image is half
the size of the original image.

File Tools View Playback Help ~
®|08 (@0 @ -
C I i =

Resady | 2691743 T=0.000

In this example, you used the Resize block to shrink an image. For more
information about this block, see the Resize block reference page in the Video
and Image Processing Blockset Reference. For more information about other
geometric transformation blocks, see the Rotate, Shear, and Translate block
reference pages.
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Cropping an Image

You can use the Selector block to crop your image or video stream. In this
example, you learn how to use the Selector block to trim an image down to a

particular region of interest:

1 Create a new Simulink model, and add to it the blocks shown in the

following table.

Block Library Quantity

Image From File Video and Image Processing 1
Blockset > Sources

Video Viewer Video and Image Processing 2
Blockset > Sinks

Selector Simulink > Signal Routing 1

2 Position the blocks as shown in the following figure.
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3 Use the Image From File block to import the intensity image. Set the File
name parameter to coins.png. The image is a 246-by-300 matrix of 8-bit

unsigned integer values.

4 Use the Video Viewer block to display the original image. Accept the

default parameters.

The Video Viewer block automatically displays the original image in the
Video Viewer window when you run the model.

5 Use the Selector block to crop the image. Set the block parameters as

follows:
e Number of input dimensions = 2

1

Index = 140

Index Option = Starting index (dialog)
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- Output Size =70
e 2
= Index Option = Starting index (dialog)
- Index =200
= Output Size = 70

E! Function Block Parameters: Selector x|

— Selector

Select or reorder specified elements of a multidimengional input signal. The index to each element iz

identified from an input port or this dialog. 'ou can chooze the indesing method for each dimenzion by
uzing the "Index Option'' parameter.

— Parameter

MHumber of input dirmensions: |2

Index miode: IDne-based LI
Index Option Index Output Size |

1 |Starting index [dialog) ;I 140 Rl
2_ Starting index [dialog) :I 200 70

Sample time [-1 far inherited]: I-'I

Ok, I Cancel Help Spply

The Selector block starts at row 140 and column 200 of the image and
outputs the next 70 rows and columns of the image.

6 Use the Video Viewerl block to display the cropped image.

The Video Viewerl block automatically displays the modified image in the
Video Viewer window when you run the model.

7 Connect the blocks as shown in the following figure.
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8 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time =0
® Solver pane, Type = Fixed-step

® Solver pane, Solver = Discrete (no continuous states)

9 Run the model.

The original image appears in the Video Viewer window.
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) Video Viewer - 10| x|
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The cropped image appears in the Video Viewer window. The following
image is shown at its true size.

6-24



Cropping an Image
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In this example, you used the Selector block to crop an image. For more
information about the Selector block, see the Simulink documentation. For
information about the imcrop function, see the Image Processing Toolbox
documentation.
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Morphological Operations

® “Overview of Morphology” on page 7-2
¢ “Counting Objects in an Image” on page 7-3

¢ “Correcting for Nonuniform Illumination” on page 7-10
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Overview of Morphology

Morphology is the study of the shape and form of objects. Morphological
image analysis can be used to perform

Object extraction

Image filtering operations, such as removal of small objects or noise from
an image

* Image segmentation operations, such as separating connected objects

e Measurement operations, such as texture analysis and shape description

The Video and Image Processing Blockset software contains blocks that
perform morphological operations such as erosion, dilation, opening, and
closing. Often, you need to use a combination of these blocks to perform your
morphological image analysis. Morphological image analysis can be used to
perform image filtering, image segmentation, and measurement operations.

The examples in this chapter show you how to use blocks from the
Morphological Operations library to count the number of objects in an image
and how to correct for uneven illumination.

For more information, see “Morphological Operations” in the Image Processing
Toolbox documentation.
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Counting Objects in an Image

In this example, you import an intensity image of a wheel from the MATLAB
workspace and convert it to binary. Then, using the Opening and Label blocks,
you count the number of spokes in the wheel. You can use similar techniques
to count objects in other intensity images. However, you might need to use
additional morphological operators and different structuring elements:

1 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity

Image From File Video and Image Processing 1
Blockset > Sources

Opening Video and Image Processing 1
Blockset > Morphological
Operations

Label Video and Image Processing 1
Blockset > Morphological
Operations

Video Viewer Video and Image Processing 2
Blockset > Sinks

Constant Simulink > Sources 1

Relational Operator Simulink > Logic and Bit 1
Operations

Display Signal Processing Blockset > Signal | 1
Processing Sinks

2 Position the blocks as shown in the following figure. The unconnected ports
disappear when you set block parameters.
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You are now ready to set your block parameters by double-clicking the
blocks, modifying the block parameter values, and clicking OK.

3 Use the Image From File block to import your image. Set the File name
parameter to testpati.png. This is a 256-by-256 matrix image of 8-bit
unsigned integers.

4 Use the Constant block to define a threshold value for the Relational
Operator block. Set the Constant value parameter to 200.

5 Use the Video Viewer block to view the original image. Accept the default
parameters.

6 Use the Relational Operator block to perform a thresholding operation
that converts your intensity image to a binary image. Set the Relational
Operator parameter to <.

If the input to the Relational Operator block is less than 200, its output is
1; otherwise, its output is 0. You must threshold your intensity image
because the Label block expects binary input. Also, the objects it counts
must be white.

7 Use the Opening block to separate the spokes from the rim and from each
other at the center of the wheel. Use the default parameters.
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] Function Block Parameters: Dpening |

—Opening [mazk] [link]

Perform morphological opening on an inkenzity or binary image.

|Jze the Heighborhood or structuning element parameter to define the neighborhood
or ghructuring element that the block applies to the image. Specify a neighborhood by
entering a matrix or wector of ones and zerog. Specify a structuning element uzing the
strel function. Altematively, you can specify neighborhood values uging the Mhood
part.

Faor further information on structuring elements, tppe doc strel at the MATLAB
command prompt,

—Parameters

MHeighborhood or structuing element source: | Specify via dialog ;I

Meighborhood ar structuring element:
|strell'dizk 5]

Cancel Help Apply

The strel function creates a circular STREL object with a radius of 5
pixels. When working with the Opening block, pick a STREL object that
fits within the objects you want to keep. It often takes experimentation to
find the neighborhood or STREL object that best suits your application.

8 Use the Video Viewerl block to view the opened image. Accept the default
parameters.

9 Use the Label block to count the number of spokes in the input image. Set
the Output parameter to Number of labels.
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E Function Block Parameters: Label x|

—Label [mazk] [link]

Labelz and counts connected components in a binary image.

At the Label port, the block outputs a label matriz where pixel: equal to O represent
the backaground, piels equal to 1 represent the first object, pixels equal to 2 represent
the second object, and zo0 on. At the Count part, block outputs a scalar that
represents the number of labeled objects.

|Jze the Connectivity parameter ta define which pisels are connected to each ather.

—Parameters
Connectivity: I g ;I
Elutput:l Mumber of labels ;I
Output data tppe; I Automatic ;I

ak I Cancel

Apply |

10 The Display block displays the number of spokes in the input image. Use
the default parameters.

11 Connect the block as shown in the following figure.

lox

File Edit View Simulaton Format Tools Help
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] Image

Image From File
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12 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set

the parameters as follows:

® Solver pane, Stop time =0

® Solver pane, Type = Fixed-step

® Solver pane, Solver = discrete (no continuous states)

13 Run the model.

The original image appears in the Video Viewerl window. To view the
image at its true size, right-click the window and select Set Display To

True Size.
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The opened image appears in the Video Viewer window. The following
image is shown at its true size.

-l

File Tools View Playback Help w
R OB & 2R || 00%
R e =

Ready [ 256256 T=0.000

As you can see in the preceding figure, the spokes are now separate white
objects. In the model, the Display block correctly indicates that there are
24 distinct spokes.
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You have used the Opening and Label blocks to count the number of spokes in
an image. For more information about these blocks, see the Opening and Label
block reference pages in the Video and Image Processing Blockset Reference. If
you want to send the number of spokes to the MATLAB workspace, use the
To Workspace block in Simulink or the Signal to Workspace block in Signal
Processing Blockset. For more information about STREL objects, see strel
in the Image Processing Toolbox documentation.

7-9



7 Morphological Operations

Correcting for Nonuniform lllumination

Global threshold techniques, which are often the first step in object
measurement, cannot be applied to unevenly illuminated images. To correct
this problem, you can change the lighting conditions and take another picture,
or you can use morphological operators to even out the lighting in the image.
Once you have corrected for nonuniform illumination, you can pick a global
threshold that delineates every object from the background. In this topic, you
use the Opening block to correct for uneven lighting in an intensity image:

1 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity

Image From File Video and Image Processing 1
Blockset > Sources

Opening Video and Image Processing 1
Blockset > Morphological
Operations

Video Viewer Video and Image Processing 4
Blockset > Sinks

Constant Simulink > Sources 1

Sum Simulink > Math Operations 2

Data Type Conversion | Simulink > Signal Attributes 1

2 Position the blocks as shown in the following figure.
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Once you have assembled the blocks required to correct for uneven
illumination, you need to set your block parameters. To do this, double-click
the blocks, modify the block parameter values, and click OK.

3 Use the Image From File block to import the intensity image. Set the File
name parameter to rice.png. This image is a 256-by-256 matrix of 8-bit
unsigned integer values.

4 Use the Video Viewer block to view the original image. Accept the default
parameters.

5 Use the Opening block to estimate the background of the image.

Set the Neighborhood or structuring element parameter to
strel('disk',15).
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] Function Block Parameters: Dpening |

—Opening [mazk] [link]

Perform morphological opening on an inkenzity or binary image.

|Jze the Heighborhood or structuning element parameter to define the neighborhood
or ghructuring element that the block applies to the image. Specify a neighborhood by
entering a matrix or wector of ones and zerog. Specify a structuning element uzing the
strel function. Altematively, you can specify neighborhood values uging the Mhood
part.

Faor further information on structuring elements, tppe doc strel at the MATLAB
command prompt,

—Parameters

MHeighborhood or structuing element source: | Specify via dialog ;I

Meighborhood ar structuring element:
|strell'dizk’ 15)

Apply

ak I Cancel

The strel function creates a circular STREL object with a radius of 15
pixels. When working with the Opening block, pick a STREL object that
fits within the objects you want to keep. It often takes experimentation to
find the neighborhood or STREL object that best suits your application.

6 Use the Video Viewerl block to view the background estimated by the
Opening block. Accept the default parameters.

7 Use the first Sum block to subtract the estimated background from the
original image. Set the block parameters as follows:

¢ Icon shape = rectangular
¢ List of signs = -+

8 Use the Video Viewer2 block to view the result of subtracting the
background from the original image. Accept the default parameters.

9 Use the Constant block to define an offset value. Set the Constant value
parameter to 80.

10 Use the Data Type Conversion block to convert the offset value to an 8-bit
unsigned integer. Set the Output data type mode parameter to uints.
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11 Use the second Sum block to lighten the image so that it has the same
brightness as the original image. Set the block parameters as follows:

® Icon shape = rectangular
® List of signs = ++

12 Use the Video Viewer3 block to view the corrected image. Accept the
default parameters.

13 Connect the blocks as shown in the following figure.
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14 Set the configuration parameters. Open the Configuration dialog box by

selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

® Solver pane, Stop time =0
¢ Solver pane, Type = Fixed-step

® Solver pane, Solver = discrete (no continuous states)
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15 Run the model.

The original image appears in the Video Viewer window.

=

File Tools View Playback Help N
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The estimated background appears in the Video Viewerl window.
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The image without the estimated background appears in the Video Viewer2
window.
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The preceding image is too dark. The Constant block provides an offset
value that you used to brighten the image.

The corrected image, which has even lighting, appears in the Video Viewer3
window. The following image is shown at its true size.
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In this section, you have used the Opening block to remove irregular
illumination from an image. For more information about this block, see the
Opening block reference page in the Video and Image Processing Blockset
Reference. For related information, see the Top-hat block reference page. For
more information about STREL objects, see the strel function in the Image
Processing Toolbox documentation.
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Example Applications

e “Pattern Matching” on page 8-2
® “Motion Compensation” on page 8-10

* “Image Compression” on page 8-12



8 Example Applications

Pattern Matching

In this section...

“Overview of Pattern Matching” on page 8-2

“Tracking an Object Using Correlation” on page 8-2

Overview of Pattern Matching

Pattern matching can be used to recognize and/or locate specific objects in
an image. It can be accomplished using several techniques, one of which is
correlation. Correlation provides a direct measure of the similarity between
two images. Though sensitive to the scaling or rotation of objects, normalized
correlation is robust to changes in lighting.

Tracking an Object Using Correlation

In this example, you use the 2-D Correlation, Maximum, and Draw Shapes
blocks to find and indicate the location of a sculpture in each video frame:

1 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity

Read Binary File Video and Image Processing 1
Blockset > Sources

Image Data Type Video and Image Processing 1

Conversion Blockset > Conversions

Image From File Video and Image Processing 1

Blockset > Sources

2-D Correlation Video and Image Processing 1
Blockset > Statistics

Maximum Video and Image Processing 1
Blockset > Statistics

Draw Shapes Video and Image Processing 1
Blockset > Text & Graphics
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Block Library Quantity

Video Viewer Video and Image Processing 1
Blockset > Sinks

Data Type Conversion | Simulink > Signal Attributes 1

Constant Simulink > Sources 1

Mux Simulink > Signal Routing 1

2 Position the blocks as shown in the following figure.
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You are now ready to set your block parameters by double-clicking the
blocks, modifying the block parameter values, and clicking OK.

3 Use the Read Binary File block to import a binary file into the model. Set
the block parameters as follows:

* File name = cat_video.bin
®* Four character code = GREY
¢ Number of times to play file = inf

e Sample time = 1/30
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E! Source Block Parameters: Read Binary File

—FRead Binary File

Fiead binary video data from file in the specified format,

—Parameters

File name: Ical_video.bin

Browze. . |

Wideo fnrmat:l Faour character codes

Four character code: I GREY

=
=

Frame size Flows:|12ﬂ Cals: |160

Line nrdering:l Top line first

|

MHumber of times to play file: Iinf

[~ Dutput end-of-file indicator

Sample time: |1,/30

Catizel

Help

4 Use the Image Data Type Conversion block to convert the data type of the
video to single-precision floating point. Accept the default parameter.

5 Use the Image From File block to import the image of the cat sculpture,
which is the object you want to track. Set the block parameters as follows:

® Main pane, File name = cat_target.png

¢ Data Types pane, Output data type = single

6 Use the 2-D Correlation block to determine the portion of each video frame
that best matches the image of the cat sculpture. Set the block parameters

as follows:

® Qutput size = Valid

e Select the Normalized output check box.
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E! Function Block Parameters: 2-D Correlation x|

—2-D Correlation

Performs bwo-dimenzional cross-correlation between bwo inputs.

Uze the Dutput size parameter to specify the dimensions of the output. Aszume that
the input at part 11 has dimensions [Ma, Ma) and the input at part 12 haz dimensions
[Mb, Mb]. If you choose Full, the output iz the full bwo-dimensional crozz-corelation
with dimenzions [Ma+hb-1, Ma+Mb-1]. If vou choose Same as input port |1, the output
iz the central part of the crosz-carrelation with the zame dimenzions as the input at
port 1. If you choose Yalid, the output iz only those parts of the cross-correlation that
are computed without the zero-padded edaes of any input. Thiz output has
dimenzions [Ma-tb+1, Ma-Mb+1].

Y'ou can normalize the output only when the input iz floating paint.

Main IFiHed-pnint I

Farameters
Cutput size:l *alid ;I
[ Momalized output

0K | Cancel Apply |

Because you chose Valid for the Output size parameter, the block
outputs only those parts of the correlation that are computed without the
zero-padded edges of any input.

7 Use the Maximum block to find the index of the maximum value in each
input matrix. Set the Mode parameter to Index.

The block outputs the zero-based location of the maximum value as a
two-element vector of 32-bit unsigned integers at the Idx port.

8 Use the Data Type Conversion block to change the index values from 32-bit
unsigned integers to single-precision floating-point values. Set the Output
data type parameter to single.
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9 Use the Constant block to define the size of the image of the cat sculpture.
Set the Constant value parameter to single([41 41]).

10 Use the Mux block to concatenate the location of the maximum value and
the size of the image of the cat sculpture into a single vector. You use this

vector to define a rectangular region of interest (ROI) that you pass to the
Draw Shapes block.

11 Use the Draw Shapes block to draw a rectangle around the portion of each
video frame that best matches the image of the cat sculpture. Accept the
default parameters.

) Function Block Parameters: Draw Shapes x|

— Diraws Shape

Draw multiple rectangles, lines, polygons, or circles on images by overwriting pixel
walues,

|1ge the Ptz port to zpecify the appropriate shape coordinates. v'ou can define the
color or intengity value of the shape's border, You can alzo chooge o fill pour shape
and specify itz opacity,

— Parameter.

Shape: IHectangles :l

The input ta the Pts port must be a four-by-M matriz where each column iz of the farm
[r & height width] and specifies a different rectangle.

[~ Fill shapes

Barder value: IBIack :I
Draw shapes in: IEntire image :I
|mage gignal: IEIne multidimenzional zignal j

QK I Cancel Help | Apply |

12 Use the Video Viewer block to display the video stream with the ROI
displayed on it. Accept the default parameters.

The Video Viewer block automatically displays the video in the Video
Viewer window when you run the model. Because the image is represented
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by single-precision floating-point values, a value of 0 corresponds to black
and a value of 1 corresponds to white.

13 Connect the blocks as shown in the following figure.
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14 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set
the parameters as follows:

¢ Solver pane, Stop time = inf
® Solver pane, Type = Fixed-step

¢ Solver pane, Solver = Discrete (no continuous states)
15 Run the simulation.

The video is displayed in the Video Viewer window and a rectangular
box appears around the cat sculpture. To view the video at its true size,
right-click the window and select Set Display To True Size.
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As the video plays, you can watch the rectangular ROI follow the sculpture
as it moves.



Pattern Matching
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In this example, you used the 2-D Correlation, 2-D Maximum, and Draw
Shapes blocks to track the motion of an object in a video stream. For more
information about these blocks, see the 2-D Correlation, Maximum, and Draw
Shapes block reference pages in the Video and Image Processing Blockset

Reference.

Note This example model does not provide an indication of whether or not
the sculpture is present in each video frame. For an example of this type of

model, type vippattern at the MATLAB command prompt.
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Motion compensation is a set of techniques that take advantage of redundancy
in consecutive video frames. These techniques are used in video processing
applications such as video compression and video stabilization. For both of
these applications, motion compensation is a two-step process of detection and
compensation. The detection step results in the specification of a motion
vector that relates two consecutive video frames. For video compression, the
compensation step involves using the motion vector to predict the current
video frame from the previous frame and encoding the prediction residual.
For video stabilization, the compensation step involves translating the
current frame in the opposite direction of the motion vector to stabilize the
video sequence.

The Video and Image Processing Blockset software contains a video
compression demo model that you can open by typing vipcodec at the
MATLAB command prompt.

E! vipcodec_intensity_win32 ;IEI il
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Motion Compensation

This demo model detects motion by analyzing how much objects move between
consecutive video frames. The model aligns two sequential video frames,
subtracts them, and codes the residual.

The Video and Image Processing Blockset software also contains a video
stabilization demo model that you can open by typing vipstabilize at the
MATLAB command prompt.

E!vipstahilize_win ;lglll

File Edit VYiew Simulation Format Tools  Help
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Frorn ubiredis File
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Fesurs

ClipBoder | 332554

Frare Fatz
® Edit
Parameters

The demo illustrates a motion stabilization technique based on the sum of
absolute differences (SAD) method. It applies the SAD technique to remove
unwanted translational camera motions and generate a stabilized video.
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In this section...

“Overview of Image Compression” on page 8-12

“Compressing an Image” on page 8-12

“Viewing the Compressed Image” on page 8-18

Overview of Image Compression

The following sections use a two-part example to show how to build a
Simulink model that is capable of image compression. In the first part of the
example, the input image is divided into blocks and the two-dimensional DCT
is computed for each block. The DCT coefficients are then quantized, coded,
and transmitted. The receiver in the second part of the example decodes

the quantized DCT coefficients, computes the inverse two-dimensional DCT
of each block, and then puts the blocks back together into a single image.
Although there is some loss of quality in the reconstructed image, it is
recognizable as an approximation of the original image.

Compressing an Image

You can use image compression to reduce the size of an image before you
transmit it. The compressed image retains many of the original image’s
features but requires less bandwidth. In this topic, you use the 2-D DCT and
Selector blocks to compress an intensity image:

1 Create a new Simulink model, and add to it the blocks shown in the
following table.

Block Library Quantity

Image From File Video and Image Processing 1
Blockset > Sources

Block Processing Video and Image Processing 2
Blockset > Utilities

Video Viewer Video and Image Processing 2
Blockset > Sinks




Image Compression

2 Position the blocks as shown in the following figure.

—ipix]

File Edit View Simulation Format Tools Help

D|D”E§|%E|<}==ﬁ>{f|92|b II'IC.C INormaI ﬂl
pepperspng  Imags o Bloz: Image v
Pro ing Frocessing Wi
|mage Fram Filz Blodk Processing Blodk Processing1 Video Viewart
Image ‘: i
idec Views
Ready [100% | | [ode4s Y

You are now ready to set your block parameters by double-clicking the
blocks, modifying the block parameter values, and clicking OK.

3 Use the Image From File block to import the intensity image into your
model. Set the block parameters as follows:

® Main pane, File name = cameraman.tif

¢ Data Types pane, Qutput data type = double

4 Use the Video Viewer block to view the original intensity image. This
1mage 1s a 256-by-256 matrix of 8-bit unsigned integer values. Accept the
default parameters.

5 The first Block Processing block represents the transmission portion of
the block diagram. This block sends 8-by-8 submatrices of the original
matrix to the block’s subsystem for processing. Use this block when you
want to perform block-based processing on large input images. To view the
subsystem, double-click the block and click Open Subsystem.
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E! Function Block Parameters: Block Processing

—Block Processing
Repeatz a user-specified operation on submatrices of the input matrix.
Thiz block extracts submatrices of a user-specified zize from the input matrix, 1t sends

each submatrix to a subsystem for processing, and then reazsembles each subsystem
output inko the output matris,

|1ge the Block size and Overlap parameters to specify the size and overlap of each
zubmatrix in cell array format,

—Parameters

Murnber of inpLits: |1

Murmber of autputs: I'I

Blck size: |{[8 6]}

Overlap: I{[D 0

Traverze order:l Row-wize v|

—Subzsystenm

Click the Open Subsystem button to open the block's subsystem, Click-and-drag
blocks into thiz subszystem to define the processing operation(z) the block performs

on submatrices.
Open Subsystem |

Apply

Ok, | Cancel

The Block Processing block’s subsystem opens.




Image Compression

E!untitIed,.-"...,.l"Blm:k iterator/sub-block i
File Edit Yiew Simulation Format  Tools  Help

=2 = = A S S T [

Place your block
processing system here.

In1 ot

To awioid unexpected behaovior fom the mask
callback function, do not ErRame input and output ports,

F|100% [ | [ode4s 4

You can drag blocks into this subsystem to process the submatrices.

6 Add the following blocks to your subsystem.

Block Library Quantity

2-D DCT Video and Image Processing 1
Blockset > Transforms

Selector Simulink > Signal Routing 1

7 Connect the blocks as shown in the following figure.
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EIuntitled,.-"...,.-"BInck iterator/sub-block - |EI|5|

File

Edit Wiew Simulation Formab  Tools  Help
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Place your block
processing system here.

|
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In1 Cut
2DDCT Selectar

To awoid unexpected behavior from the mask
callback function, do not Ename input and output pons.
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8 The 2-D DCT block takes the two-dimensional DCT of each submatrix. This
process puts most of the energy in the image into the upper left corner of
the resulting matrix. Use the default parameters.

9 Use the Selector block to extract the upper left corner of the submatrix.
Set the block parameters as follows:

¢ Number of input dimensions = 2

¢ Index mode = Zero-based

1

Index Option = Starting index (dialog)
Index =0
Output Size = 4

Index Option = Starting index (dialog)
Index =0
Output Size = 4



Image Compression

=] Function Block Parameters: Selector x|

—Selector

Select or reorder specified elements of a multidimensional input signal. The index to
each element is identified from an input part or this dialog. You can choose the
indexing method for each dimension by using the “Index Option” parameter.

—Parameters

Mumber of input dimensions: I 2

Index mode: Izern:n-hased

Index Option Index | Qutput Size
Starting index (dialog) LI ]
2 |starting index (dialog) ;I ]
Sample time (-1 for inherited): I -1
oK Cancel Help Apply

You are using the Selector block to compress the image by extracting

the upper left corner of the submatrix, which contains the high energy
image coefficients. You want to transmit only this portion of the submatrix
because it requires less bandwidth than transmitting the entire submatrix.

10 Close the subsystem and the Block Processing dialog box.

You have now configured the Block Processing and 2-D DCT blocks to
compress an image for transmission. In “Viewing the Compressed Image” on
page 8-18, you use the 2-D IDCT block to transform the image back to the
time domain. Then, you view the compressed image.
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Viewing the Compressed Image

In “Compressing an Image” on page 8-12, you compressed an image using
the 2-D DCT and Selector blocks. Now, you can use the 2-D IDCT block to
transform the image back to the time domain and view the result:

1 If you have not already done so, set the Image From File block to import
the intensity image into your model. Set the block parameters as follows:

® Main pane, File name = cameraman.tif

¢ Data Types pane, Output data type = double

2 If the model you created in “Compressing an Image” on page 8-12 is not
open on your desktop, you can open an equivalent model by typing

doc_compressing_an_image
at the MATLAB command prompt.

3 Use the Block Processing1 block to set the size of the submatrices that the
block passes to the subsystem. Set the Block size parameter to {[4 4]}.



Image Compression

E! Function Block Parameters: Block Processingl

— Block Processing
Repeats a uzer-specified operation on submatrices of the input matrix.

Thiz block extracts submatrices of a uzer-specified zsize from the input matris. It zends
each submatrix to a subspztem for processing, and then reassembles each subsystem

autput inka the output matris.

Uze the Block size and Overlap parameters to zpecify the size and overlap of each
submatrix in cell array formnat.

— Parameter

Mumber of inputs: |1

Murmber of autputs: I'I

Block size: |{[4 4]}

Dverlap: I{[EI o

Traverse order; IHow-wise vl

— Subzystem

Click the Open Subsysztem button to open the block's subzystem. Click-and-diag
blocks into thiz subszystem to define the processing operationfz] the block performs

on submatrices.
Open Subzsystem |

oK I Cancel | Help Apply

following blocks to it.

4 Open the block’s subsystem by clicking Open Subsystem, and add the

Block Library Quantity

Image Pad Video and Image Processing 1
Blockset > Utilities

2-D IDCT Video and Image Processing 1
Blockset > Transforms
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5 Connect the blocks as shown in the following figure.

EIuntitled,.-"...,.-"BInck iterator/sub-block - |EI|5|
File Edit Wiew Simulation Format Tools  Help

e

Place your block
processing system here.

Image Fad 20 IDGT

In1 out
2-DI0BST

L J

Irnzge Pad

To awioid unexpected behavior fom the mask
callback function, do not Ename input and output ports.

F[100% | | |odes 4

6 Use the Image Pad block to zero pad the 4-by-4 submatrix back to its
original 8-by-8 size. Set the block parameters as follows:

* Pad rows at = Right
* Pad size along rows = 4
¢ Pad columns at = Bottom

e Pad size along columns = 4
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=1 Function Block Parameters: Image Pad x|

—Image Pad (mask) {ink)

Perform two-dimensional padding of an input image.

Pad your image by adding rows to the top and/or bottom of your image and
columns to the left and/for right side of your image. To specify a different padding
size at the top and bottom or left and right side of your image, use a two-element
vector, The first element denotes the padding at the top or left side of your image.
The second element denotes the padding at the bottom or right side of your image.

‘fou can pad your matrix with a constant value, specified by the Value parameter or
the PVal input port. In addition, you can pad your matrix by repeating its border
values, using its mirror image, or using a circular repetition of its elements.

—Parameters
Method: ICDnstant ;I
Pad value source; ISDEEiﬁ.-' via dialog ;I
Pad value:
o
Specify: IF‘au:I gize ll
Pad rows at: IRight |

Fad size along rows:

4

Pad columns at: |Bottom ;I

Pad size along columns:

4

Ok Cancel Help Apply

8-21



8 Example Applications

8-22

Because zeros are replacing the low energy transform coefficients, the

output image is an approximation of the original image.

7 The 2-D IDCT block takes the inverse two-dimensional DCT of the
submatrices. Accept the default parameters.

8 Close the subsystem and the Block Processingl dialog box.

9 Use the Video Viewerl block to view the compressed image. Accept the

default parameters.

10 Connect the blocks as shown in the following figure.

E! doc_compressing_an_image *

Help

File Edit View Simulation Format Tools
D IEsEHE| +t 2R | 4|22 ll1:.: | Nomal =l
cameraman tif  Irmage - F':E;:ir'-; E— F':E;;r-; L Image \:::':f:
Imags From Fils Blodk Frooessing Blodk Proosssing1 Vides Views
L pfimage /1%
Video Views
Ready [100% | | |ode4s

11 Set the configuration parameters. Open the Configuration dialog box by
selecting Configuration Parameters from the Simulation menu. Set

the parameters as follows:
® Solver pane, Stop time =0

® Solver pane, Type = Fixed-step



Image Compression

® Solver pane, Solver = Discrete (no continuous states)
12 Run the model.

The original image is displayed in the Video Viewer window.

=

File Tools View Playback Help N
W08 &«a @ B 5
=@

Resady [ 256x256 T=10.000

The compressed image is displayed in the Video Viewerl window. The
compressed image is not as clear as the original image. However, it still
contains many of its features.
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In this example, you used the 2-D DCT, Image Pad 2-D IDCT, and Block
Processing blocks to compress an image. For more information on these
blocks, see the 2-D DCT, Image Pad, 2-D IDCT, and Block Processing block
reference pages in the Video and Image Processing Blockset Reference. For
information on the Selector block, see the Simulink documentation. For more
information on sharpening an image, see .
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